XP filepicker totally broken (no save as, save image, file input, etc)

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: doeni.bug, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040309
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040309

When trying to save an image to the local disk, nothing happens.
The Save as dialog does not pop up, no file is stored on the local disk

The Javascript console reports the following error :
Error: Components.classes[fpContractID] has no properties
Source File: chrome://communicator/content/contentAreaUtils.js 
Line: 718

Reproducible: Always
Steps to Reproduce:
1. Open a page containing an image
2. Right click on 'Save image as'

other testcase:
1. Open a page containing an image
2. Right click on 'View Image'
3. Select File -> 'Save Page as'
Actual Results:  
nothing happens. The file is not saved locally

Expected Results:  
The Save File dialog should pop up

Before including the fix for bug 235832 'Save image as' used to crash Mozilla.
Since this bug has been fixed, the crashes do not occur anymore, though the save
dialog does not appear anymore.



Build options :
--enable-default-toolkit=gtk2 --enable-calendar --enable-xft
--disable-postscript --disable-xprint --enable-crypto --disable-installer
--disable-debug --enable-optimize=-O3
(Reporter)

Comment 1

15 years ago
correction, I meant since the fix for bug 235201 has been included.
Not bug 235832 (which is not fixed)
hm, you have no registered filepicker?

try deleting compreg.dat and restarting mozilla...
(Reporter)

Comment 3

15 years ago
Same problem, same message in the JS console.

I tried :
- Removing compreg.dat
- creating a new profile

But in both cases, still seeing the same problem.
hm. Do you have an nsFilePicker.js in your components/ directory?
(Reporter)

Comment 5

15 years ago
yes, it is there :

doeni:local/mozilla/components> ll nsFilePicker.js
-rw-r--r--    1 doeni    users       10660 Nov  9 20:14 nsFilePicker.js
I'm seeing the same thing with a mozilla.org 2004-03-09-08 nightly.

I am NOT seeing it with a 2004-03-08-08 nightly.

Almost certainly fallout from bug 235882 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.7b?
Summary: save image as does not save image → XP filepicker totally broken (no save as, save image, file input, etc)

Comment 7

15 years ago
*** Bug 236950 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
From duped bug, when selecting save page as you get the following message in the
JS console:
Error: [Exception... "Component returned failure code: 0x80040154
(NS_ERROR_FACTORY_NOT_REGISTERED) [nsIDownload.init]"  nsresult: "0x80040154
(NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame ::
chrome://communicator/content/contentAreaUtils.js :: foundHeaderInfo :: line
404"  data: no]
Source File: chrome://communicator/content/contentAreaUtils.js
Line: 404

Dupe was on WinXP OS->All
Adding regression keyword too
Keywords: regression
OS: Linux → All
That bug is not this bug.
OS: All → Linux
Fixed by dbaron's update to bug 235882
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Flags: blocking1.7b?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.