All users were logged out of Bugzilla on October 13th, 2018

Colon in search show in sidebar as %3A

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: richard, Assigned: neil)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

When using the Search Sidebar, a colon (:) inside the search is escaped to %3A
which make pressing the "Search" button to perform another search. In Mozilla
1.5 and below the colons were not escaped, and pressing the "Search" button gave
exactly the same results.

Reproducible: Always
Steps to Reproduce:
1. Using the Siderbar, search (using Google) for "site:mozilla.org search"
2. The Search Sidebar will say: "site%3Amozilla.org search"
3. Click the Siderbar's "Search" button
4. The found results will differ from step 1

Actual Results:  
A different search is performed

Expected Results:  
The same search should be performed
(Reporter)

Comment 1

15 years ago
I just upgraded to Mozilla 1.7 (Linux version). This problem is still there! Can
someone please test this so that the status can be set to NEW?

Updated

15 years ago
Assignee: search → neil.parkwaycc.co.uk
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 2

15 years ago
Created attachment 151096 [details] [diff] [review]
Proposed patch
(Assignee)

Comment 3

15 years ago
Comment on attachment 151096 [details] [diff] [review]
Proposed patch

More bug 44272 fallout... note that jshin used encodeURIComponent in the same
file in the same patch :-(
Attachment #151096 - Flags: superreview?(alecf)
Attachment #151096 - Flags: review?(timeless)

Comment 4

15 years ago
Comment on attachment 151096 [details] [diff] [review]
Proposed patch

doh. sr=alecf
Attachment #151096 - Flags: superreview?(alecf) → superreview+

Updated

15 years ago
Attachment #151096 - Flags: review?(timeless) → review+
(Assignee)

Comment 5

15 years ago
Fix checked in.
(Assignee)

Comment 6

15 years ago
Really marking fixed :-[
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

14 years ago
*** Bug 285021 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.