[mozTXTToHTMLConv]Brackets break link for URL in message

RESOLVED DUPLICATE of bug 133016

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 133016
15 years ago
10 years ago

People

(Reporter: Martijn Ras, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Hmm... well something should be said for that webmaster's horrific display of
knowledge.  No website should create a URL that long.  Secondly, it's pretty
standard to urlencode() if you got non-alphanumeric characters such as "(" since
there's always an email client, or browser, or something messing it up.

As per RFC1738:
>   Thus, only alphanumerics, the special characters "$-_.+!*'(),", and
>   reserved characters used for their reserved purposes may be used
>   unencoded within a URL.
>
>   On the other hand, characters that are not required to be encoded
>   (including alphanumerics) may be encoded within the scheme-specific
>   part of a URL, as long as they are not being used for a reserved
>   purpose.

So I guess it is a bug.  But I'd say it's also bad webmastering on behalf of
sciencedirect.

Product: Browser → Seamonkey
*** Bug 291496 has been marked as a duplicate of this bug. ***
Component: MailNews: Main Mail Window → MailNews: Backend
Product: Mozilla Application Suite → Core
QA Contact: esther
Summary: Brackets break link for URL in message → [mozTXTToHTMLConv]Brackets break link for URL in message

*** This bug has been marked as a duplicate of 133016 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.