multiple items highlighted in context menu

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Eli orginally saw this last week --i'm able to repro this with today's comm bits
on winNT and linux (2000011108 and 2000011110, respectively). Eli, did you see
this occur on Mac as well? (i haven't tried with today's bits...yet.)

anyhow,
the really annoying thing here is figuring out the precise steps to make
this
thing show up. here is a possible recipe --but if doesn't work, feel free
to
come over to my cube so that i can attempt to repro it for ya!

1. startup
seamonkey, turn off the Sidebar.
2. go to a non-framed page (for simplicity's
sake).
3. over some whitspace or non-linked text (again, just to keep this
simple),
bring up the context menu --no items should be highlighted at this
point.
4. move the mouse over an item (eg, Back) so that it becomes highlighted.
5. click the item a couple times (with the right-mouse button), which should do
nothing (bug 17159 or bug 21459).
6. move the mouse pointer outside the context
menu, and click again (with right
button) to dismiss the context menu.
7. bring
up the context menu again.
8. repeat steps 1-7 for another item, eg, Reload.

result: the context menu somehow has the previously highlighted items
highlighted again.

expected: when you bring up the context menu, nothing should
be highlighted.
(Reporter)

Comment 1

18 years ago
modification of step 5 above: keep clicking with the right button till the item
remains highlighted. this seems to be key to making the highlighting 'stick'
after doing steps 6 and 7...

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M16

Comment 2

18 years ago
Marking M16

Comment 3

18 years ago
sairuh --- sorry for slow response. Yes, I can reproduce this on Mac in under 30
seconds. (2000011310 build)
(Assignee)

Updated

18 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW
(Assignee)

Comment 4

18 years ago
Taking menu/popup bugs.
(Assignee)

Comment 5

18 years ago
sure, the clicking again with the right button causes problems, but i can't 
actually dupe the exact problem listed here. there is a different problem, so 
marking as a dupe of that.


*** This bug has been marked as a duplicate of 24482 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
(Reporter)

Comment 7

18 years ago
i can still repro this. also, i don't understand how this could be a dup of bug
24882. so, reopening.

i'd be happy to come over to demo/discuss this in person. :-)
Status: RESOLVED → REOPENED
(Reporter)

Updated

18 years ago
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

18 years ago
we know there are problems with right menu clicks while a context menus is up 
that put things into a very strange state. I'm not surprised that things don't 
behave correctly. should we make this dependant on that other bug instead of 
marking as a dupe? And yes, i would like to see it.
(Assignee)

Comment 9

18 years ago
bulk accepting xpmenu/popup bugs. sigh.
Status: REOPENED → ASSIGNED
(Reporter)

Comment 10

18 years ago
chatted with pinkerton --is annoying to repro, but it's there. ;-)  prolly
dependent on bug 24482, so adding it as such.
Depends on: 24482
(Assignee)

Comment 11

18 years ago


*** This bug has been marked as a duplicate of 24482 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

18 years ago
why was this re-marked as a dup of 24482? i still think this is a separate
issue... but i welcome additional/new information to the contrary... :-)
(Assignee)

Comment 13

18 years ago
oops, didn't see the dependency.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M16 → M17

Comment 14

18 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18
(Reporter)

Comment 15

18 years ago
*** Bug 36030 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

18 years ago
*** Bug 40085 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
people were saying they were having diffculty reproducing...the method i
described in bug 40085 seems to work very easily on linux.

Comment 18

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21
(Reporter)

Comment 19

18 years ago
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm

Comment 20

18 years ago
I cannot reproduce this with the procedure listed here, nor the procedure from
40085.  This bug seems to have been silently fixed.  Suggest
RESOLVED/WORKSFORME.  Tested on Linux Build 2000060620 (M17).
(Assignee)

Comment 21

18 years ago
wfm.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.