Incorrect layout for scrollable DIVs

VERIFIED DUPLICATE of bug 237015

Status

()

VERIFIED DUPLICATE of bug 237015
15 years ago
15 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Run the sample code included. Try resizing the browser window and notice how the
scrollable text does not resize properly. Refreshing the page fixes the layout.

Not sure if that is a problem, but removing the inner DIV and moving the style
to the TD element does not work at all. Shouldn't TD also accept overflow style
attribute?

-------------

<html>
<body>

<center>

<table>
<tr>
<td><div style="overflow: auto;"><nobr>scrollable scrollable scrollable
scrollable scrollable</nobr></div></td>
<td><nobr>FIXED FIXED FIXED</nobr></td>
</tr>
</table>

</center>

</body>
</html>

Reproducible: Always
Steps to Reproduce:
As discribed above. Try resizing from maximized view down to a small window and
back. Refresh from time to time to see the changes in the layout.


Expected Results:  
I believe the layout after refresh should be the correct one. Resizing the
window should give the same layout as refresh does.

*** This bug has been marked as a duplicate of 237015 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.