Hebrew from LXR/Bonsai "looks" wrong

RESOLVED INVALID

Status

()

Core
Layout: Text
--
minor
RESOLVED INVALID
15 years ago
10 years ago

People

(Reporter: timeless, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:) Gecko/20040307

http://ooo.ximian.com/lxr/source/framework/binfilter/inc/bf_svx/globlmn.hrc#2635
2605 #define ITEM_EDIT_REDO \
2606     Identifier = SID_REDO ; \
2607         Command = ".uno:Redo" ; \
2608     HelpID = SID_REDO ; \
2609     Text = "Wiederherstellen unm�glich" ; \
2610     Text [ english_us ] = "Can't Restore" ; \
2611     Text [ portuguese_brazilian ] = "N�o � poss�vel Restaurar" ; \
2612     Text [ swedish ] = "�terst�lla om�jligt" ; \
2613     Text [ danish ] = "Kunne ikke gendanne" ; \
2614     Text [ italian ] = "Impossibile ripetere" ; \
2615     Text [ spanish ] = "No se puede restaurar" ; \
2616     Text [ french ] = "Impossible de restaurer" ; \
2617     Text [ dutch ] = "Herstellen onmogelijk" ; \
2618     Text [ portuguese ] = "Imposs�vel restaurar" ;\
2619         Text[ chinese_simplified ] = "无法恢复撤消命令";        \
2620         Text[ russian ] = "���������� ������������";    \
2621         Text[ polish ] = "Nie mo�na przywr�ci�";        \
2622         Text[ japanese ] = "やり直しできません";       \
2623         Text[ chinese_traditional ] = "無法復原";   \
2624         Text[ arabic ] = "�� ���� ���������";   \
2625         Text[ dutch ] = "Herstellen onmogelijk";        \
2626         Text[ chinese_simplified ] = "无法恢复撤消命令";        \
2627         Text[ greek ] = "��������� ��������";   \
2628         Text[ korean ] = "복구 불가능";    \
2629         Text[ turkish ] = "Tekrar Olu�turulam�yor";     \
2630         Text[ language_user1 ] = " ";   \
2631         Text[ catalan ] = "No es pot restaurar";        \
2632         Text[ finnish ] = "Ei voi palauttaa";   \
2633         Text[ thai ] = "ไม่สามารถคืนสภาพได้";     \
2634         Text[ czech ] = "Nelze ~obnovit";       \
2635         Text[ hebrew ] = "לא ניתן לשחזר";      \
2636         Text[ hindi ] = "पूर्व अवस्था में नहीं पहुँचा सकते है";     \
2637         Text[ slovak ] = "Nie je možné obnoviť";

http://ooo.ximian.com/bonsai/cvsblame.cgi?file=framework/binfilter/inc/bf_svx/globlmn.hrc&rev=1.1#2635
2605 hjs   1.1 #define ITEM_EDIT_REDO \
2606               Identifier = SID_REDO ; \
2607           	Command = ".uno:Redo" ; \
2608               HelpID = SID_REDO ; \
2609               Text = "Wiederherstellen unm�glich" ; \
2610               Text [ english_us ] = "Can't Restore" ; \
2611               Text [ portuguese_brazilian ] = "N�o � poss�vel Restaurar" ; \
2612               Text [ swedish ] = "�terst�lla om�jligt" ; \

2613               Text [ danish ] = "Kunne ikke gendanne" ; \
2614               Text [ italian ] = "Impossibile ripetere" ; \
2615               Text [ spanish ] = "No se puede restaurar" ; \
2616               Text [ french ] = "Impossible de restaurer" ; \
2617               Text [ dutch ] = "Herstellen onmogelijk" ; \
2618               Text [ portuguese ] = "Imposs�vel restaurar" ;\
2619           	Text[ chinese_simplified ] = "无法恢复撤消命令";	\
2620           	Text[ russian ] = "���������� ������������";	\
2621           	Text[ polish ] = "Nie mo�na przywr�ci�";	\
2622           	Text[ japanese ] = "やり直しできません";	\
2623           	Text[ chinese_traditional ] = "無法復原";	\
2624           	Text[ arabic ] = "�� ���� ���������";	\
2625           	Text[ dutch ] = "Herstellen onmogelijk";	\
2626 hjs   1.1 	Text[ chinese_simplified ] = "无法恢复撤消命令";	\
2627           	Text[ greek ] = "��������� ��������";	\
2628           	Text[ korean ] = "복구 불가능";	\
2629           	Text[ turkish ] = "Tekrar Olu�turulam�yor";	\
2630           	Text[ language_user1 ] = " ";	\
2631           	Text[ catalan ] = "No es pot restaurar";	\
2632           	Text[ finnish ] = "Ei voi palauttaa";	\
2633           	Text[ thai ] = "ไม่สามารถคืนสภาพได้";	\
2634           	Text[ czech ] = "Nelze ~obnovit";	\
2635           	Text[ hebrew ] = "לא ניתן לשחזר";	\
2636           	Text[ hindi ] = "पूर्व अवस्था में नहीं पहुँचा सकते है";	\
2637           	Text[ slovak ] = "Nie je možné obnoviť";

Steps to reproduce:
1. do research for composer
2. find openoffice
3. find openoffice cvs oriented webtools
4. find reference to string of interest
5. examine adjacent strings
6. boggle

7. copy the LXR text (line 2635)
8. win-r (run dialog from explorer, aka start>run)
9. paste
9' (see footnote 1)
10. copy that
11. paste that into mozilla's edit bug form
11'
2635         Text[ hebrew ] = "לא ניתן לשחזר"
this line intentionally included
12. copy the bonsai text (line 2635)
13. as 8
14. as 9
14' (see footnote 2)
15. paste into mozilla' edit bug form
15' 2635           	Text[ hebrew ] = "לא ניתן לשחזר";	\

footnote 1:
2635         Text[ hebrew ] = "□רזחשל ןתינ אל□"
note that this is reformated manually to match the look of the run dialog.

footnote 2:
2635         □Text[ hebrew ] = "□רזחשל ןתינ אל□";□\

footnote 3:
I don't have chinese fonts for w2k for this laptop, so those items are almost
certainly ruined.
Disclamer:  I stink when it comes to content-type and different characters (nor
would I know what it *should* look like).  So this is partially for my own
education.

Shouldn't the page have content-type meta tag?

<meta http-equiv="content-type" content="text/html; charset=UTF-8">
Hmm...looking at the LXR page, some of the strings appear to be in ISO-8859-1
(e.g., French), and others appear to be in UTF-8 (e.g., Hebrew). I don't think
this is a Mozilla bug.
(Reporter)

Comment 3

15 years ago
robert: 'not really'. meta types tend to cause mozilla/4 to reload the page.
wrt choess's comment, that'd probably be a real problem. but i'm still unsure
that our behavior is reasonable.
(In reply to comment #1)
> Shouldn't the page have content-type meta tag?
> 
> <meta http-equiv="content-type" content="text/html; charset=UTF-8">

An HTTP Header would be better, but the content has to be in the specified
encoding... and you lose anyway if it is in several different ones.

timeless: mozilla/5 too, I believe, at least in some cases.
It's not clear what this bug is really about. 

If the problem in "6. boggle" is the misordering of the punctuation around the
Hebrew texts, then the only solution as far as I am aware is for the source page
to add extra markup or styling, e.g. a CSS rule like this:

.string { unicode-bidi: embed; }

The extra double quotes in stage 15 look like bug 177442

Comment 6

14 years ago
Created attachment 150525 [details]
Screenshoot and Question ...

Hello 

I have read this error message and I have a short question about the problem.
For myself I have installed the Hebrew and the Greek support of W2000. I can
read the hebrew text and I cannot read the Greek text (shown by a screenshoot).


Why?

Best regards 
Wolfgang Uhr
That's because of what choess mentions in comment 2. If you change Character
Coding to ISO-8859-7 you will see the Greek correctly and the Hebrew as garbage.

Comment 8

14 years ago
This should be closed as invalid. There's nothing Mozlla can do about
mixed-encoding text like this horrible mess. 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

14 years ago
comment 5 pretty much describes why i filed the bug. i'm partly trying to figure
out if i can do anything to improve lxr/bonsai. are there any hazards in using
that css rule? (i.e. is there some input for which that style will break things
worse than not having it)

Comment 10

14 years ago
In that case, you should file a bug on Webtools/Lxr and provides a clean 
testcase with a well-defined character encoding.
(In reply to comment #9)
> are there any hazards in using
> that css rule? (i.e. is there some input for which that style will break things
> worse than not having it)

I don't think so. Ideally you would also want |direction: rtl| for strings in
right-to-left languages, but I doubt if there is anyway to set that
automatically when you need it in this context. 
(Reporter)

Comment 12

14 years ago
well defined encoding? hah. lxr/bonsai deal w/ real source files like the urls
referenced in this bug. which it would seem mix encodings (i haven't figured out
what kind of editor people use such that they don't corrupt the string tables...).

i'll file a bug (if i haven't already) once i figure out what i can do.
(Reporter)

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.