All users were logged out of Bugzilla on October 13th, 2018

URL link with backward slash doesn't work with the Mozilla Firebird ( and the Suite. )

RESOLVED DUPLICATE of bug 64488

Status

RESOLVED DUPLICATE of bug 64488
15 years ago
14 years ago

People

(Reporter: jongampark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

PDF files linked with <A href .. tag is not accessible with the Mozilla based
browser, like the Firefox. However the MS IE accesses the links well.
The wierd thing I found in the HTML source code is that the links have backward
slach,'\', instead of forward slash, '/'.
Well, using the backward slash may violate the HTML standard, but wouldn't it be
better if the Mozilla also treats the backward slash well?


Reproducible: Always
Steps to Reproduce:
1. open the given URL, http://www-scf.usc.edu/~csci576b/lectures.html
2. Click on any link
3. Check if files are being downloaded or "can't find such a file"-like message
is displayed.

Actual Results:  
The mozilla can't access the linked resources.

Expected Results:  
Successful accessing the linked resource.

Comment 1

15 years ago
but Why should Mozilla change a url?
the webmaster has created that page and maybe he has a very good reason to use a
backslash and if Mozilla changes it to a forward slash then he will say that
Mozilla is stupid. If he meant to use a backslash then the best thing to do is
that he changes the page.
If he ever looks at the server logs he should realize that there are request to
files that doesn't exist in the server (remember it's the server the one that
it's giving the error message) and then fix the broken links.

This is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
To Alfonso Martinez  

Did you try the html page? It is normal link with normal intention.
I am 100% sure that the author of the page was confused with the backward slash
and the forward slash. And he may test it with the MS IE.
The MS IE allows backward slash with URL, and it treats the backward slash like
forward slash. So, he may think that his HTML file is OK for public view,
although it really isn't.

Anyway the MS IE allows the backward slash.

Do you think that using the backward slash should be prohibited?
If so, my report is invalid.
Verified invalid.  This has come up often before.  It's a bug in IE's URL handling.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
Shouldn't that be a dup of bug 176312 ?
Product: Browser → Seamonkey
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.