If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 231048
14 years ago
9 years ago

People

(Reporter: Kocil, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

If Firefos downloads the same file several time, it renames it as :

idesk-0.5.6.tar.gz
idesk-1.5.6.tar.gz
idesk-2.5.6.tar.gz
.....

OR

idesk-0.5.6-i386-1.tgz
idesk-1.5.6-i386-1.tgz
idesk-2.5.6-i386-1.tgz
...

While not hurt, changing the version number of the file 
is not right.

Should be better if firefox smart enough to rename it as
idesk-0.5.6-1.tar.gz
idesk-0.5.6-2.tar.gz
...

idesk-0.5.6-i386-1.tar.gz
idesk-0.5.6-i386-2.tar.gz
idesk-0.5.6-i386-3.tar.gz
..

Algorithm hint:
- From behind, skip for non numeric extensions.
- find numeric followed by dash (-)
- increment the numeric

Thanks


Reproducible: Always
Steps to Reproduce:
1. Download a file with version number
2. Repeat the download several times


Actual Results:  
in the detail

Expected Results:  
in the detail

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.