Download manager automatically closes when file is downloaded

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Kevin Ar18, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+

Any time a file is done downloading, the download manager automatically closes
it's window.

Reproducible: Always
Steps to Reproduce:
1. Download a file
2. The download manager appears
Actual Results:  
When the file is done downloading, the download manager closes.

Expected Results:  
The download manager should remain open.

Under normal circumstances, users wishes to open the file after is it
downloaded.  Because the download manager closes everytime a file is downloaded,
they have to go through extra steps to open the file.

Comment 1

14 years ago
Go to Tools | Options | Downloads and switch off the pref that tells the
download manager to close after downloads are completed.

This feature is already implemented. Later on we will have a clickable link from
the all files completed downloads biff notification to open the download manager
again if the user wants.

--> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Another issue that this causes is that the download manager loses focus even
when the user is doing something to the download manager.  In other words,
without warning, the window the user is working on suddenly disappears when they
are in the middle of doing something in that window.

In such a case, should this issue be fixed?
(Reporter)

Comment 3

14 years ago
Note: The options window also closes (if launched from the download manager).
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.