Closed Bug 23711 Opened 20 years ago Closed 20 years ago

Changing what is saved if user re-enters data in form?

Categories

(Toolkit :: Form Manager, defect, P3)

Other
Linux
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: mikebabcock, Assigned: morse)

Details

If the user fills in a form and responds "OK" to having that data saved, then
returns at a later date and fills in a field differently, shouldn't Mozilla
prompt the user whether they want the changes saved?
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
I'm a little confused here as its not clear if this refers to the wallet feature
or to the single signon feature.

The single-signon feature is for forms that contain a password.  When ever such
a form is submitted you always get a prompt asking if you want to save these
values (unless you haven't changed them).  And those saved values are
automatically prefilled when you return to the same form but not used for any
other form.

The wallet feature is for forms that do not contain passwords.  You are never
prompted about saving data on such forms.  Instead you have to take some special
action (currently selecting a menu item, in the future perhaps pressing a button
in the chrome) to effect the save.  Same is true for for the fillin.  And values
that you save on one form might get used for the fillin on some other form if it
is appropriate.

Now the question here is about the user responding OK to having the data saved.
So I presume he is talking about single-signon (because wallet doesn't ask the
question).  If you then return at a later date and submit the same form but with
a different value, you will indeed get prompted again as to whether you want to
save the changes.  If this is not what you are observing, then please give me a
detailed scenerio of steps that get you to a form for which you will not get
asked the question.

Closing this out as invalid until a detailed scenerio is presented that proves
me wrong.
verifying.
Status: RESOLVED → VERIFIED
This is an old report now, but I decided to clarify, now that I'm using a much
newer incarnation of Mozilla.

I was talking about what you refer to as the single sign-on feature, although
under the menus its simply the password manager.  The issue is slightly
different now (and that's part of why I've revisited this bug report) -- if I
enter a username and password for a login, and accept to have them saved, they
are saved and filled in for me the next time.

If I revisit the same site, then change the username and password (because I
have another login) and decide to accept the question again (to save those
values), both sets of values are saved in the PSM, but its not clear which set
will be entered the next time I visit that site -- shouldn't the PSM ask to
replace the old set of values?
If you revisit a site after saving more than one set of values for it, the 
password manager puts up a dialog listing all the saved values and asks you to 
select the one you want.  This is the correct behavior.

It would be wrong to replace a saved value just because the user saved a new 
value.  Here's an example showing why.  I have two accounts for my mutual funds 
-- one in my name and one in my wife's.  Each has a separate login.  But I 
administer both accounts and therefore sometimes have to log in with one 
username and sometimes with the other.  I want password manager to help me out 
by saving both logins and letting me pick the one that I want whenever I return 
to the site.
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
You need to log in before you can comment on or make changes to this bug.