'https' URLs are not conifgurable in 'allow popup windows' under Web Features

RESOLVED INVALID

Status

()

Firefox
Preferences
--
major
RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: HenryH, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In the page http://www.stgeorge.com.au (a bank!) the log-in (right hand side of
page) uses javascript to open a new window to enter log-in details. If pop-up
blocking is enabled, it is not possible to allow the pop-up for this site. 
Entering the site URL produces "www.stgeorge.com.au" in the allow-window.
Entering https://www.stgeorge.com.au also produces "www.stgeorge.com.au" in the
allow-window.
I have not checked this with sites with a URL of the format http://sitename.tld

Reproducible: Always
Steps to Reproduce:
1. Tools
2. Options
3. Web features
4. Add site
5. Enter the site to unblock (https.www.sitename.com)
6. OK

Actual Results:  
www.sitename.com was entered in the "Allways allow..." window.

Expected Results:  
https://www.sitename.com should have been entered in the "Allways allow..." window.

Comment 1

14 years ago
The https part of the URL is the protocol scheme, it is not part of the domain
and you shouldn't need to enter it. My guess is that you are trying to whitelist
"www.stgeorge.com.au" but the popup is actually coming from
"ibank.stgeorge.com.au" so is still blocked. If you try adding "stgeorge.com.au"
or "ibank.stgeorge.com.au" to the Popup allow box it should work.
Permissions are set by host, not by protocol.  The correct component for an 
enhancement to allow limiting to secure sites would be Browser->Popup Blocking, 
but I fully expect that this would not be accepted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
(In reply to comment #1)
> The https part of the URL is the protocol scheme, it is not part of the domain
> and you shouldn't need to enter it. My guess is that you are trying to whitelist
> "www.stgeorge.com.au" but the popup is actually coming from
> "ibank.stgeorge.com.au" so is still blocked. If you try adding "stgeorge.com.au"
> or "ibank.stgeorge.com.au" to the Popup allow box it should work.

Yes it does work.  Looking at the source for the page gives me this info.  Thank
you.

There is still the issue that an average, unsupported, user would not know to
look at the source code for the page to see why "it doesn't work", nor would
they be interested/able to get this assistance from bugzilla.  It's not a bug in
the code, per se, it is an issue which the user will have and which will
convince them that "it's broken"!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
as reported, this is invalid.  The problem lies only in the fact that the page
redirects again when the popup doesn't display (watch the bottom corner, it'll
show up and if you click it shows the correct site)

There's bugs on that already, go ahead and look for them if you want to add
further comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.