Improper display of 'Create in' drop down list.

RESOLVED DUPLICATE of bug 228582

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 228582
14 years ago
11 years ago

People

(Reporter: Saurabh Gupta, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The 'Create in' drop down list depicts an improper display behavior. When
viewing the list, the listed bookmark folders are randomly selected, rather than
being displayed in an organized manner. (Refer attachment of snapshots)

This inconsistency exists irrespective of selecting the root folder or any sub
folder.

Reproducible: Always
Steps to Reproduce:
1.Add a considerable number of folders and subfolders to the bookmark root 
  folder.(say 4 folders and 4 subfolders)
2.Go to 'Add Bookmark', 'Create in' list and click on it to view the items of 
  the list.
3.Compare the items displayed and the folders that are displayed in the 
  window(frame)below.

Actual Results:  

The list does not display the root folder with it subsequent main folders. It
rather displays a random selection of folders and sub folders and to select a
particular folder to store in, one needs to select from the frame below.

Expected Results:  

The list should display atleast the root folder with its subsequent main folders
(if not all the folders and subfolders).


Follow up Tests:
----------------
1. Closing the browser or reinstalling the browser does not do away with this 
   issue.
2. Deleting all the folders and subfolders and then again adding the folders and 
   subfolders depicts the same behavior.
3. Clicking on a particular folder does not list the subfolders (pehaps not in 
   functionality), neither does selecting Bookmark root folder, display the main
   folders of the root folder. Hence selecting any folder does not display the 
   subfolders under that folder.


Importance of the Bug:
----------------------
1. For I.E. (considering it as an Oracle) the bookmark folders are displayed by
default when the 'Add Favorites' option is clicked. Although the sub folders are
 not expanded, however the main folders are displayed. Firefox does display the
folders in a similar manner in the display frame, however the list does not
display folders as expected.
*Since the drop down list is an added feature, it should function properly and
in conjunction with the display frame.

2. Using the drop down list the users cannot select all(most) of the folders or
sub-folders, to store bookmarks. This is again an issue with the functionality
(added functionality) and it should depict expected behavior.
(Reporter)

Comment 1

14 years ago
Created attachment 143623 [details]
Snapshot of improper behavior(1)

This snapshot shows the display before clicking the drop down list.
(Reporter)

Comment 2

14 years ago
Created attachment 143624 [details]
Snapshot of improper display (2)

This snapshot shows the inconsistency in drop down list, of displaying the main
bookmark folders.

Comment 3

14 years ago
This looks like a FF issue and not a Mozilla issue.
->FF-Bookmarks
Component: Bookmarks → Bookmarks
Product: Browser → Firefox
QA Contact: seamonkey.bookmarks → mconnor
Version: Trunk → unspecified
no, they're not randomly selected, they're based on the last folders that had
bookmarks added to them.  Its intended to be adaptive, and the treeview option
is for when the most recent five folders aren't where you're looking for.

Duping to the bug that had the initial discussion on this, and will be revisited
after 0.9 to determine if we are going to utilize only a simple treeview.

Also, since I know most of the FIT testing is part of a class, I'm going to pick
a couple nits with the reporting of this bug.  First, the IE Add Bookmark dialog
does not default to show the treeview.  However, it does persist the
shown/hidden state of the treeview, which means that most people just leave it
open.  Second, if the design was intended to show the treeview in the dropdown,
as you so obviously expect, what would be the point of expanding the treeview. 
Third, referring to IE as an Oracle really misses the entire point of creating a
new browser designed for greater ease of use than IE, which includes tossing on
its ear the idea of conforming to existing UI.

*** This bug has been marked as a duplicate of 228582 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.