Closed Bug 237170 Opened 18 years ago Closed 17 years ago

onmouseup/down fired wrong on relative position

Categories

(Core :: DOM: Events, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: gerbert, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

Here we go...

When you attach onmousedown/up events to multiple relative positioned div's, and
then do a mousedown on one div and a mouseup on another, it will have the
mousedown element as the mouseup. :)

Please view the attached testcase.

cya,
Gerbert Kaandorp





 



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Attached file Demonstrates event bug
Ehhh... I mean:

on relative divs,
When you do a mousedown on div 1
move your mouse to div 2
do a mouseup. it will have  div 1 as target

sorry, too much coffee ;)
Depends on: 53966
I see this on LInux 2004041207
OS: Windows XP → All
Looks like the patch for bug 53966 fixed this bug, too. Tested with a Linux
trunk build from today.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.