text-align of a DIV doesn't align also a contained DIV

VERIFIED DUPLICATE of bug 22816

Status

()

Core
Layout: Block and Inline
VERIFIED DUPLICATE of bug 22816
14 years ago
14 years ago

People

(Reporter: Lapo Luchini, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219

In a "DIV in a DIV" structure, the inner DIV is placed in the wrong place.

Reproducible: Always
Steps to Reproduce:
Take a look at the attached page.
Actual Results:  
The page is not rendered correctly.

Expected Results:  
The page is rendered correctly.
(Reporter)

Comment 1

14 years ago
Created attachment 143676 [details]
testcase
text-align aligns text.  It does not affect block layout.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
http://www.w3.org/TR/2004/CR-CSS21-20040225/text.html#propdef-text-align
Maybe I got it completely wrong, but doesn't the documentation say "Applies to
any block-level elements"?
Else, how to center a block?
margin-left: auto;
margin-right: auto;
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 22816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
"applies" just means that you can apply the property to any block and that it
will center the text inside that block.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.