Status

Thunderbird
Account Manager
--
critical
RESOLVED DUPLICATE of bug 209188
15 years ago
14 years ago

People

(Reporter: David Barreña Molina, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

Browsing Imap folders, the connection with te server is lost frequently.
The server is Linux Red-Hat 8.0, with postfix and courier-Imap, with ssl (port 
993).
If I make the connection without ssl (port 143), everything is ok.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Got the same problem here. 
The server is Gentoo, with Courier-imap-ssl. The connection is lost *very* often. 
(Often enough to force me to use Outlook)
*** Bug 243052 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
well, I can confirm the bug for 0.6+ trunk thunderbird and 0.6 release. it is
really annoying and one of the most make-thunderbird-look-bad-bugs in the thing
:-) and should be taken care of. 
(Assignee)

Comment 4

14 years ago
this sounds like a dupe

*** This bug has been marked as a duplicate of 209188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
What do you mean by "disconnections"? Do you get an alert that says the server
has disconnected? Or do things just spin not doing anything? Please try a recent
trunk thunderbird build (from the last couple days) and let me know if it still
happens. If it does, an imap protocol log would be interesting:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Created attachment 149225 [details]
IMAP log file

I was able to reproduce the bug with Thunderbird 0.6 (couldn't figure out how
to get a CVS build for windows) on win2k with IMAP SSL (log attached). It
happens when browsing folders on an IMAP server. After having changed the
folder a few times, I get an alert saying: 'Server mail.alrua.dk disconnected.
The server may have gone down or there may be a network problem'.
The server is running courier-imap version 3.0.2-r1. The only thing I can see
in the server logs are a bunch of LOGINs and LOGOUTs.

Comment 7

14 years ago
As far as I can tell this is not a duplicate of bug 209188 which has completely
different symptoms: it makes the thunderbird icon spin indefinitely while this
bug makes a popup window appear, stating "Server xyz has disconnected. The
server may have gone down or there may be a network problem".

Also, I can confirm this with thunderbird 0.7.1 running on RH9 and connecting to
courier imap on freebsd and suse.
(Reporter)

Comment 8

14 years ago
The problem persist in the latest version 0.7.2.
(Reporter)

Comment 9

14 years ago
The problem persist in the latest version 0.7.2.

Comment 10

14 years ago
you need to limit the number of imap connections tbird will cache to 4, imap
server settings panel of your account setup, by clicking the advanced button,
and changing the default 5 to 4. Your courier imap server by default limits the
number of connections from a single ip address to 4 (this number can be
increased on the server side as well)
(Reporter)

Comment 11

14 years ago
I think that it solves the problem

Comment 12

14 years ago
This indeed works, but why does thunderbird disconnects so badly from the server
when a single connection from the pool is closed by the remote side?

Comment 13

14 years ago
the server connects, and then disconnects immediately - that's rather rude, and
we got an unexpected error from the networking code. The fix was to check for
this new error code and put up an error message.
You need to log in before you can comment on or make changes to this bug.