Bad parsing <!-- -------------- --> string

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Other
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Eugene Seppel, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040219 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040219 Firefox/0.8

In the page at
http://redu.russia.webmatrixhosting.net/Site/view.aspx?Site=SPC&Section=HSchool
The Html data between two <!--
-------------------------------------------------- --> comments is ignored by
browser, if first string 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN-RU" > in document
exist. This bug also avaliable in other pages with same syntax.

Reproducible: Always
Steps to Reproduce:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN-RU" >
<html>
<head><title>wrong page</title></head>
<body>
string 1
<!-- -------------------------------------------------- -->
string 2
<!-- -------------------------------------------------- -->
</body>
</html>

Actual Results:  
"string 1" is exists in browser window
but "string 2" not.
Also you can see html-source with Firefox with same results -- "string 2" is
showed in green color

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 233270 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Shouldn't this be reassigned to tech evang?

Updated

15 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
Yes... reopening and changing to Tech Evangelism.

See bug 233270, comment 1 for explanation.
Assignee: firefox → other
Status: UNCONFIRMED → NEW
Component: General → Other
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: other

Comment 4

11 years ago
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.8.1.7) Gecko/20071013 Firefox/2.0.0.7

I can confirm that this  bug still exists and it seems DTD related. It seems to affect all Gecko based browsers like Epiphany.

To reproduce:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xml:lang="en" lang="en" xmlns="http://www.w3.org/1999/xhtml"> 
<head> 
<title>TNTforum -> Taker/Batista History</title> 
</head> 
<body>
<div class='postcolor'>BEFORE<br /><!--YoutubeBeginlBMw7--yVTs#test--><table width='95%'><tbody><tr><td width='100%'><hr><b><span style='color:red'><span style='font-size:16pt;line-height:100%'>&nbsp;test&nbsp;</span></span></b><br /><object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/lBMw7--yVTs"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/lBMw7--yVTs" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350"></embed></object><br /></td></tr></tbody></table><!--YoutubeEndlBMw7--yVTs#test--><br />
AFTER</div>
</body>
</html>

Without the DTD header the page is parsed correctly, but with that header Firefox incorrectly thinks that most of the div thing is a comment.

Comment 5

11 years ago
OK, I just found that bug 233270 contains relevant informations about the whole story.
Sorry for the noise.
Domain gone
Status: NEW → RESOLVED
Last Resolved: 15 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.