Preferences window tree is blank

RESOLVED WORKSFORME

Status

SeaMonkey
Preferences
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: asa, Unassigned)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
from bug 236467:

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7b) Gecko/20040304
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7b) Gecko/20040304

Preference Panel can be accessed only once per launch of Moz. Suite 1.7x.  If a
second attempt to access the panel is made w/i the same session, panel is not
displayed and behaves as a "no-op" or nil condition, i.e. no action.  Pref.
panel, when displayed is milling entries in its left pane.  Left Pane is blank.
 This condition does not occur in Moz. 1.6.

Reproducible: Always
Steps to Reproduce:
1. Launch Moz. 1.7x
2. Click on "Preferences" in "Mozilla" drop-down menu in toolbar.
3. Preference Panel will display with its left pane blank.
4. Click "OK" and panel closes.
5. Repeat step #2.  Panel will not be displayed.



Actual Results:  
1. Flawed Preference Panel is displayed once.
2. Panel will not display a second time.

Expected Results:  
Moz. Suite should properly display its Preference Panel as many times as
required by the user in the same session, w/o relaunching.

This condition may be unique to the Mac OSX version of Mos. Suite 1.7x
(Reporter)

Comment 1

15 years ago
See http://bugzilla.mozilla.org/attachment.cgi?id=142927&action=view 

I am unable to reproduce this problem with the latest nightly builds on OS X
(Panther) using both classic and modern themes. I'll test more on 10.2 and 10.1
shortly.
(Reporter)

Comment 2

15 years ago
Also unable to reproduce with 10.2 in modern or classic themes. I've tested with
new and 1.4 and 1.5 created profiles. I also tested the 1.7a release build. 
(Reporter)

Comment 3

15 years ago
OK. also tested on 10.1 and cannot reproduce with current nightly or 1.7alpha.

Comment 4

15 years ago
Created attachment 144260 [details]
Mozilla Prefs Panel fails to render properly

Mozilla Prefs Panel fails to render properly, even with the latest nightly
build of 1.7.b (Mac OSX 10.3.3).  Looks like same problem, new bug #.

Comment 5

15 years ago
It did not reproduce in my environment.
see.
http://bugzilla.mozilla.org/show_bug.cgi?id=236467#c4
(Reporter)

Comment 6

15 years ago
*** Bug 186147 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
I am able to reproduce this on Windows 2000.

The preferences window (Mozilla 1.7rc3) will either open entirely blank, or it
will not open at all.

Comment 8

14 years ago
Created attachment 150617 [details]
Preferences tree (on left pane) is blank

Comment 9

14 years ago
Created attachment 150618 [details]
Relevant (problematic ?) file access entries during preference window opening

This is a trancated list of file accesses as generated by the FileMon utility.
(the list was much longer, but these were the only problematic entries)

The list was generated at the moment of mouse-click on the "Edit-->Preferences"
menu entry.

Comment 10

14 years ago
Creating a new profile seems to solve the problem

Comment 11

14 years ago
(In reply to comment #10)
> Creating a new profile seems to solve the problem 

I concur.  It appears that obliterating all previous traces of Moz. and building a new profile will 
also work for the Mac.

Comment 12

14 years ago
I've just installed Mozilla 1.7 under Windows XP Professional and have the same
problem (first time the preferences dialog is empty and unusable, second time it
will not display at all).

Creating a new profile had no effect / doesn't help.

My version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Comment 13

14 years ago
*** Bug 250130 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-AT; rv:1.8a1) Gecko/2004052008
OS X 10.2.6

same problem. 1.6 had an only-once phenomenon - you could not call up the prefs
dialog 2 times. now everything is broken; the user profiles have no influence.

Comment 15

14 years ago
*** Bug 261681 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
The OS should be set to All.

Updated

14 years ago
OS: MacOS X → All
Product: Browser → Seamonkey

Comment 17

14 years ago
All the same with 1.8a4 Mac. removing the prefs.js file does not help anything.
stripping prefs.js fron unnecessary lines also fails. waht now? ijust can not
change my prefs!!!!

Comment 18

14 years ago
Created attachment 168700 [details]
My preferences window

December 2004 - still empty...

Updated

14 years ago
Flags: blocking1.8a6+
(Reporter)

Comment 19

14 years ago
Please do not set bugzilla blocking + flags. That is reserved for
drivers@mozilla.org
Flags: blocking1.8a6+

Comment 20

14 years ago
The Following Fixed it for me Mac OS X 10.3.7 and Mozilla 1.8a5
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-AT; rv:1.8a5) Gecko/2004112206

 Find your profile directory. Delete the file XUL.mfl (Windows) or XUL.mfasl
(Mac OS X / Linux). There should be a sub-directory called chrome. Remove
everything in chrome. This will not affect things like your mail data or
preferences. You will then need to re-install any themes/extensions you want
using versions compatible with your application.

after that it can use the preferences menue.

Comment 21

13 years ago
Created attachment 195755 [details]
Menu box showing highlighteed perf menu, hidden

Comment 22

11 years ago
WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 23

11 years ago
Since I switched to Version 2.0 and there is no preferences tree anymore, the problem doesn't exist anymore. 
You need to log in before you can comment on or make changes to this bug.