Caret disappears from text element under fixed position hidden div box

RESOLVED DUPLICATE of bug 167801

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 167801
16 years ago
10 months ago

People

(Reporter: whitehousetim, Assigned: roc)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040312 MultiZilla/1.6.0.0e
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040312 MultiZilla/1.6.0.0e

When a text input element is beneath a hidden div box which has hidden
visibility the caret is not visible although typing is not affected. In this
example of HTML the caret will gradually disappear as the text input is scrolled
beneath the fixed box. Also tested on Firefox Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8 and on Linux as well as
Windows XP. Changing the z-index didn't seem to affect the display.

<html><head></head>
<body>
<div style="">No caret here: <input type="text" /></div>
<div style="position:absolute; top:150px;">Scroll up and this caret
disappears<input type="text" /></div>
<div style="position:fixed; width:400px; height:100px; visibility:hidden;"></div>
<table height="1600px"></table>
A tall table and some text to enable scrolling up the text element
</body>
</html>


Reproducible: Always
Steps to Reproduce:
1. Create a page using the HTML from the details.
2. Load the created page in the browser.
3. Place the focus in the first text input element and no caret is visible.
4. Place the focus in the 2nd text input element and there is a caret.
5. Scroll the window so the 2nd text element goes under the hidden div and the
caret will disappear.


Actual Results:  
As noted in the steps the caret is not visibile over the hidden div.

Expected Results:  
The caret should be visible even when over the div with hidden visibility.
Dup of the "caret paints to its widget directly instead of being a good painting
citizen" bug....
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Updated

6 years ago
Whiteboard: DUPEME
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.