css is ignored, when "Every time I view the page" is checked.

VERIFIED FIXED in mozilla1.7beta

Status

()

Core
Networking: HTTP
P1
major
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: matsuba, Assigned: Darin Fisher)

Tracking

({regression})

Trunk
mozilla1.7beta
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7b) Gecko/20040312 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040312

css is ignored. when "Every time I view the page" is checked.


Reproducible: Always
Steps to Reproduce:
1. install mozilla-i686-pc-linux-gnu-2004-03-12-09-trunk.tar.gz
2. Mozill start.
3. Go http://www33.ocn.ne.jp/~snip/mozilla/, loading css is ok.
4. Edit -> Preferences -> Advanced -> Cache,
  Select "Every time I view the page" and applies by using [OK],
5. Push "reload", css is ignored.

6. Edit -> Preferences -> Advanced -> Cache,
  Select "When the page is out of date" and applies by using [OK],
7. Push "Reload", css is loaded correctly.




2004-03-05-09-trunk: OK
2004-03-06-10-trunk: OK
2004-03-08-10-trunk: OK

From 2004-03-09-09-trunk: NG
(Reporter)

Updated

15 years ago
Summary: css is ignored, when "Every time I view the page" is checked. → css is ignored, when "Every time I view the page" is checked.
This is a regression from bug 232385 

When loading the page with that cache setting, I get two instances of:

WARNING: NS_ENSURE_TRUE(mCachedResponseHead) failed, file
/home/bzbarsky/mozilla/xlib/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 1041

The site is loading the same sheet from each of the three frames.

My guess is that what happens is that the first frame starts the sheet load and
then the other two frames fail to get write access to the cache entry or
something when they try to do the same, since the first load is still in
progress.  Now the content in the cache entry is _not_ valid (since we have the
"recheck with server every time" flag set).  So we don't just ReadFromCache(). 
But we only got read access to the cache, so we CloseCacheEntry(), which blows
away our mCachedResponseHead.  Once that's null, we bail out of
ProcessNotModified with the warning I pasted above...
Assignee: general → darin
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
Flags: blocking1.7b?
Keywords: regression
QA Contact: general → httpqa
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.7beta
(Assignee)

Updated

15 years ago
Blocks: 232385
a=dbaron for backing out bug 232385, as requested in email to drivers
(Assignee)

Comment 3

15 years ago
fixed by backing out my patch for bug 232385.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

15 years ago
My build from cvs on Mon Mar 15 16:15 JST 2004:
Verified Fixed.

Build 2004-03-14-09-trunk: Linux
It appears to not be working now on linux.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Flags: blocking1.7b?
You need to log in before you can comment on or make changes to this bug.