Doesn't work with some javascript inside???

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: gabriel.klein, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8


If you have this page... it doesn't work!
But if you replace the XN--RVE-FMA.CH by a XN-RVE-FMA.CH it works!
No Javascript error...

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">
<html>
<head>
<!--
<script language="javascript">
function dopage() {
    ZZZNULLZZZ.location ="http://XN--RVE-FMA.CH";
}
</script>
-->
</head>
<frameset frameborder="0" framespacing="0" border="0" rows="100%,*">
    <frame name="MYTOPFRAME" src="http://www.nuage.ch" noresize>
    <noframes>
       	<body>
           <h1>No Frames...</h1>
        </body>
    </noframes>
</frameset>
</html>

Reproducible: Always
Steps to Reproduce:
(I have tested it on FireFox... Not on mozilla)
1. Open http://www.xn--rve-fma.ch/
2. Save the page. (If you use www.rêve.ch you cannot save the page...)
3. Change http://XN--RVE-FMA.CH inside the saved page and remove the -- it works!
----- Alternate
1. Create a page with the html code given in "details" part.
2. Try to load the page.
3. Change the line with the --
4. Try to load the page again.
Actual Results:  
--> Is displayed

Expected Results:  
Accept the -- in the function
(Reporter)

Comment 1

15 years ago
Created attachment 143802 [details]
A page that show the bug
(Reporter)

Comment 2

15 years ago
NOTA: I use mydomain.com and perhaps they will add a workaround to this bug...

Gab
That's because there is content ("-->") before the frameset, causing the
frameset to be ignored. The sgml markup declaration starts at '<!', the comment
begins with the '--' immediately after that and ends with the second '--',
inside the url string; the sgml markup declaration ends with the '>' at the end
of '</script>'. See
<http://www.w3.org/TR/REC-html40/intro/sgmltut.html#h-3.2.4>. A solution is to
break up the url "http://XN--RVE-FMA.CH" as "http://XN-" + "-RVE-FMA.CH".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
All that would be true if this were not inside a <script> tag.  But the code in
question _is_ inside a <script> tag and hence should not be tokenized as HTML.

We have a bug already on this comment thing... we have it for IE compat in some
other situations, but somehow IE manages to handle this case differently...
Status: RESOLVED → UNCONFIRMED
OS: Windows XP → All
Hardware: PC → All
Resolution: INVALID → ---
Whiteboard: DUPEME
The <script> is inside the comment, so I don't think that's the problem. I think
Tuukka's right. It looks to me like it's IE that's broken here; why it's parsing
a <script>...</script> inside a comment, I can't imagine.
Yikes.  Right you are.  The script is inside the comment.

The report does not say things work as in the script runs.  Just that the page
renders.  And that's due to IE's buggy comment parsing....

Re-resolving invalid.  Tuukka Tolvanen, my apologies.

Oh, and for what it's worth saving http://www.rêve.ch works just fine...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.