Allow option to trust REMOTE_USER for authentication

RESOLVED DUPLICATE of bug 166794

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 166794
15 years ago
6 years ago

People

(Reporter: cneberg, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+

It should be possible to leave authenticaton up to the web server and not the
bugzilla application.  Internally companies already have authentication schemes
they user for web servers: mod_ldap, mod_kerb, mod_negotiateauth, SSL Client
authentication, web sso products such as pubcookie, netegreity, oblix, etc.  All
of these modules/apps can set REMOTE_USER.

In order for this to work the login name must optionally be different than the
email address.

When a user creates an account they should be able to set their email address
and full name.  Of course in this arrangement they should NOT be able to set
their username, it should just be pulled from REMOTE_USER.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

15 years ago
Depends on: 218917

*** This bug has been marked as a duplicate of 166794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 218917
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.