Camino unexpectedly quits upon attempt to open application

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: forums, Assigned: mikepinkerton)

Tracking

({crash})

Details

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.7
Build Identifier: 

Upon attempting to open Camino the icon will bounce in the dock, stop bouncing for around a second 
and than a dialogue box will appear stating that Camino has unexpectedly quit. One never even sees a 
splash screen. Incidentally this same behavior presents itself with Netscape 7.1, Mozilla 1.6 and 1.7a 
and Firefox 0.8

Reproducible: Always
Steps to Reproduce:
1. Locate program icon
2. Either double click, press "command-o" or "command-down arrow"
3. cry
Actual Results:  
Icon bounced in the dock, stopped bouncing for around a second 
and than a dialogue box appeared stating that Camino had unexpectedly quit.

Expected Results:  
The software should have presented me with a browser window

Comment 1

15 years ago
Daniel, build 20040312 works for me.  Can you post your Camino version (bugzilla
used your Safari agent string) and attach the crash report from the Console log
to this bug?
(Reporter)

Comment 2

15 years ago
Camino version is 0.7+


Here is what the log spits out:

/Applications/Camino 0.7+.app/Contents/MacOS/Camino: can't map file: /Applications/Camino 
0.7+.app/Contents/MacOS/plugins/MRJPlugin.plugin ((os/kern) invalid argument)
/Applications/Camino 0.7+.app/Contents/MacOS/Camino: can't map file: /Library/Internet Plug-Ins/
QuickTime Plugin.plugin ((os/kern) invalid argument)
/Applications/Camino 0.7+.app/Contents/MacOS/Camino: can't map file: /Library/Internet Plug-Ins/
DRM Plugin.bundle ((os/kern) invalid argument)
/Applications/Camino 0.7+.app/Contents/MacOS/Camino: can't map file: /Library/Internet Plug-Ins/
Windows Media Plugin ((os/kern) invalid argument)
/Applications/Camino 0.7+.app/Contents/MacOS/Camino: can't map file: /Library/Internet Plug-Ins/
Java Applet.plugin ((os/kern) invalid argument)
(Reporter)

Comment 3

15 years ago
Created attachment 143842 [details]
Camino crash log

This is actually the crash log. My former post was from Console

Comment 4

15 years ago
Daniel, 0.7+ indicates a nightly build. What is the build ID? (See the About
window.)
Severity: major → critical
Keywords: crash
(Reporter)

Comment 5

15 years ago
Unless there is some way of finding out the build ID other than through the about box we're out of luck. 
Camino has to be able to successfully start to get to the about box and that is the problem: Camino 
never successfully starts. Any ideas?
(Reporter)

Comment 6

15 years ago
Created attachment 143875 [details]
Saved directly after a "Mozilla 1.6" failure to open
(Reporter)

Comment 7

15 years ago
Created attachment 143876 [details]
Saved directly after a "Mozilla 1.7a" failure to open
(Reporter)

Comment 8

15 years ago
Created attachment 143877 [details]
Saved directly after a "Netscape 7.1" failure to open
(Reporter)

Comment 9

15 years ago
Created attachment 143878 [details]
Saved directly after a "Firefox 0.8" failure to open
(Reporter)

Comment 10

15 years ago
Incidentally, I have

- Mozilla 1.0.2, 1.6, 1.7a
- Firefox 0.8
- Netscape 7.1

The only browser out of all of these that works is Mozilla 1.0.2. The others do exactly the same thing as 
Camino: they never open, giving me the "unexpectedly quit" box. I have included, in case they are 
helpful, the crash logs for these apps as well. Each crash log has the name of the application that 
crashed right before I dragged a copy of it to the desktop and saved it.

Comment 11

15 years ago
Have any of those programs worked for you in the past? If so, have you upgraded
anything (Java, a media player, a flash plugin, etc.) recently?
(Reporter)

Comment 12

15 years ago
Camino worked for me in the past. To be honest with you it has been a long time. The most recent 
posts - including mine - at the MozzilaZine forums concerning the Camino problem are from last year 
(with no solution) and I just figured out how/took the time to use Bugzilla. So it is hard for me to 
remember what it was I may have upgraded. I had stopped using Camino after Safari came out and 
after, I would say, a few months I attempted to start it up again to no avail.

I hope that the other crash reports from the various Mozilla related applications are helpful. Was there 
some big change in the code between Mozilla 1.0.2 and 1.6 that might be involved?

Comment 13

15 years ago
The first thing to do is download the most recent nightly to make sure it's not
already fixed (that will also give you a build ID, basically, since the build
number is just the compile date):
http://ftp.mozilla.org/pub/mozilla.org/camino/nightly/latest/

If that still doesn't work, you might try moving everything /Library/Internet
Plugins/ somewhere else temporarily, to see if something bad is going on with
your plugins, as your crashlog seems to suggest (to my untrained eye at least)
(Reporter)

Comment 14

15 years ago
And to think it could have been so easy. The "magic" file in the /Library/Internet
Plugins/ was one called "NPDownLoadPhotoCarbon". I have no idea what it does (besides crash all 
Mozilla based browsers, that is). All of the aformentioned browsers open now and I see that everybody 
save Netscape and Mozilla want to look like Safari. I want my cartoony icons back in Camino. Thanks for 
all of your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.