no way to print a child window

RESOLVED DUPLICATE of bug 204519

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED DUPLICATE of bug 204519
14 years ago
11 years ago

People

(Reporter: arthur glassman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

You have not implemented the ability to print a child window.  Print is only
available from the top level window, which since it takes the focus away cannot
print the child window.

Reproducible: Always
Steps to Reproduce:
1.  Go to a web site
2.  pop up a child window
3.    Gee whiz.  You forgot to implement any way to print this window!

Actual Results:  
gee whiz.  No way to print the child window

Expected Results:  
You need to add 1 or more of these 3 things-
1. right click menu on a child window gives option to print it
2. put print option onto the button bar of child windows
3. in the top level window print - provide an option to print instead the child
window

Severity - I'd call this MAJOR - but it's not something that is in the code and
broken, it's a glaring oversite that should have been there in Mozilla and
FireFox from day one and people keep omitting, perhaps because they would prefer
sites never make use of pop up windows for their core functionality.  I have
news for you, many sites do make use of pop up child windows, and thank God you
provide the ability to allow pop ups on selected sites.

The simplest quick fix is probably to add the print option to the right click on
a child window, the same as you'd have the option to print or save an image you
clicked on.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 204519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.