Closed Bug 23745 Opened 21 years ago Closed 21 years ago

[DOGFOOD][BLOCKER] Cannot start Mail

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3, blocker)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: huang, Assigned: scottputterman)

References

Details

Linux 2000-01-12-08-M13 commercial build:

I can start browser, but after select Tasks|Mail, the application just exit
automatically..... I cannot start mail at all.

I got following info from the console:

 ./mozilla -installer
.//run-mozilla.sh ./mozilla-bin -installer
MOZILLA_FIVE_HOME=/home/khuang/seamonkey/package
  LD_LIBRARY_PATH=/home/khuang/seamonkey/package:/home/khuang/seamonkey/package/
Cool
      XPCS_HOME=/home/khuang/seamonkey/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nNCL: registering deferred (0)
WEBSHELL+ = 1
title string = [Profiles and Migration]
WEBSHELL- = 0
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback error: Can't initialize.
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
nsCollationUnix::Initialize mLocale = C
nsCollationUnix::Initialize mCharset = ISO-8859-1
/home/khuang/seamonkey/package/Cool/Xpcs Registry.dat: invalid ELF headerWEBSHEL
L+ = 3
WEBSHELL+ = 4
title string = [Mozilla]
Setting content window
browser.startup.page = 1
startpage = http://home.netscape.com/
in SetSecurityButton
title string = [Mozilla - Mozilla]
! nsSecureBrowserUIImpl found: chrome://navigator/content/navigator.xul
change lock icon to unlock ?(chrome 0)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)
got a request
change lock icon to unlock - new document
title string = [Netcenter - Mozilla]
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
Document http://home.netscape.com/ loaded successfully
Document: Done (8.203 secs)
! nsSecureBrowserUIImpl found: http://home.netscape.com/
change lock icon to unlock ?(http 0)
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
WEBSHELL+ = 7
change lock icon to unlock - new document
title string = [Mail - Mozilla]
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)
title string = [Mozilla]
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
title string = [Netscape Communications Services - Mozilla]
./mozilla-bin: error in loading shared libraries: /home/khuang/seamonkey/package
/components/libraptorhtml.so: undefined symbol: CreateAndPostReflowCommand__7nsF
rameP12nsIPresShellP8nsIFrameQ216nsIReflowCommand10ReflowTypeT2P7nsIAtomT5
Assignee: phil → putterman
I think ScottP already fixed this, so I'm reassigning to him and marking fixed
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
specifying a comment to keep bugzilla happy
QA Contact: lchiang → cpratt
Change QA contact to cpratt, Cc: Lisa since this is build problem.
QA Contact: cpratt → huang
Changing QA contact back to reporter. It may be a build problem, but it's not my
area to verify. (FWIW, this isn't the only unexpected quit in this build.)
OK. Then I will verify it once we get the new build.
*** Bug 23750 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
Linux Redhat 6.0 (2000-01-13-08 M13)
I have no problem starting mail in this morning's build using -mail option or
Task|mail in POP and IMAP accounts.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Fenella, have you removed the .mozilla directory?
After I removed .mozilla directory and used today Linux commercial build...
still cannot start the mail.
The Netscape Quality Feedback Agent Prompt after the application automatically
exit. Reopenning this bug now!!

Copy the console info as following:

./mozilla -installer
.//run-mozilla.sh ./mozilla-bin -installer
MOZILLA_FIVE_HOME=/home/khuang/seamonkey/package

LD_LIBRARY_PATH=/home/khuang/seamonkey/package:/home/khuang/seamonkey/package/Cool
      XPCS_HOME=/home/khuang/seamonkey/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nNCL: registering deferred (0)
WEBSHELL+ = 1
nsXULKeyListenerImpl::Init()
Move window by 274.5,216.5
title string = [Select User Profile]
start with profile: msg41_qt30
WEBSHELL- = 0
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
nsCollationUnix::Initialize mLocale = C
nsCollationUnix::Initialize mCharset = ISO-8859-1
/home/khuang/seamonkey/package/Cool/Xpcs Registry.dat: invalid ELF
headerWEBSHELL+ = 3
WEBSHELL+ = 4
title string = [Mozilla]
Setting content window
browser.startup.page = 1
startpage = http://home.netscape.com/
in SetSecurityButton
JavaScript Error: uncaught exception: [Exception... "Illegal value"  code:
"-2147024809" nsresu
lt: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location:
"chrome://sidebar/content/sidebarOverlay.j
s Line: 201"]

title string = [Mozilla - Mozilla]
! nsSecureBrowserUIImpl found: chrome://navigator/content/navigator.xul
change lock icon to unlock ?(chrome 0)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)
got a request
change lock icon to unlock - new document
title string = [Netcenter - Mozilla]
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
Document http://home.netscape.com/ loaded successfully
Document: Done (6.985 secs)
! nsSecureBrowserUIImpl found: http://home.netscape.com/
change lock icon to unlock ?(http 0)
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
WEBSHELL+ = 7
change lock icon to unlock - new document
title string = [Mail - Mozilla]
LL+ = 4y¡%change lock icon to unlock ?(about 0)d¹)change lock icon to unlock -
new documents/¸change lock icon to unlock - new document
start message pane with:
http://messenger.netscape.com/bookmark/4_7/messengerstart.html
In sortColumn
in showthreads
In onLoadfolderPane
In sortColumn
SetupCommandUpdateHandlers
got a request
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: chrome://messenger/content/messenger.xul
change lock icon to unlock ?(chrome 0)
title string = [Redirect Messenger Start - Mozilla]
! nsSecureBrowserUIImpl found:
http://messenger.netscape.com/bookmark/4_7/messengerstart.html
change lock icon to unlock ?(http 804b0002)
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
title string = [Netscape Communications Services - Mozilla]
Document: Done (1.478 secs)
! nsSecureBrowserUIImpl found: http://home.netscape.com/messenger/start/
change lock icon to unlock ?(http 0)
imap://qatest30@nsmail-5
In ChangeFolderByURI
title string = [qatest30 on nsmail-5 - Mozilla]
change lock icon to unlock - new document
FolderPaneController.IsCommandEnabled(button_delete)
FolderPaneController.IsCommandEnabled(cmd_selectAll)
FolderPaneController.IsCommandEnabled(cmd_delete)
title string = [Mozilla]
Document: Done (0.711 secs)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about
0)
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
I just found that there was a bug#23832.
After narrowed down this problem,
I believe that today's commercial build problem is more similar to bug#23832,
I can start mail, but just crashed after I selecting/switching folders.
Marking as verified!!
Status: RESOLVED → VERIFIED
Marking as verified!!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.