other selected messages are marked as read if first message selected is unread

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: chris, Unassigned)

Tracking

Trunk
x86
NetBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7a) Gecko/20040314
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7a) Gecko/20040314

When I select several messages at once in the mail client using IMAP the mail
client marks all the messages that I have selected as read as soon as it
finished loading the first message that I clicked on.  I am running on a slow
internet connection using an IMAP server so this gives me several seconds to
select other messages.  This may or may not apply to POP3, its hard to test
because its so fast.  This started appearing in Mozilla 1.7a and worked properly
in 1.6.

Reproducible: Always
Steps to Reproduce:
1.  Select any unread message on an IMAP server
2.  Before it has a chance to fully load that message, select another by holding
down Control or Shift and clicking on another message (note:  it doesn't seem to
matter how many other messages you select)
3.  Watch all messages that are selected be marked as read
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 1

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7a) Gecko/20040314

Thanks for the report, however this is a very old build. please try a newer
version and reopen if still a problem.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/
or 
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.