Crash when playing any Real media files using Real Alternative 1.21

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: codewzrd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When trying to play any Real files using the plugin provided by Real Alternative
1.21, Firefox crashes.  This is happens on any Real files played using the
browser plug-in.

I have installed Quicktime Alternative, Real Alternative, and Media Player Classic.



Reproducible: Always
Steps to Reproduce:
1. Go to http://www.raaga.com/channels/hindi/top10.asp
2. Click on a song link (next to the star rating).
3. Firefox pops up a new window. Assuming that, that is where the plugin is
being loaded.

Actual Results:  
A dialog box pops up.  Dr. Watson I think.  "Firefox has generated errors.  An
error log is being created."


Expected Results:  
Play the file without crashing.
(Reporter)

Comment 1

15 years ago
Created attachment 143910 [details]
Dr. Watson log file.

Contains stack trace file.

Comment 2

14 years ago
mozilla 1.6 creates the same crash over here..

btw. i'm using real alternative 1.22
(Reporter)

Comment 3

14 years ago
Yes same thing happens with Real Alternative 1.22.

Forgot to mention this earlier in my first post; it works great with IE 6 (both
versions 1.21, 1.22). :(  No crashes, no problems.

Comment 4

14 years ago
.. but wrong browser :D

Comment 5

14 years ago
mozilla 1.6 still crashes when using real alt v1.23

Comment 6

14 years ago
A problem with real alternative, rather than Mozilla?

Comment 7

14 years ago
(In reply to comment #6)
> A problem with real alternative, rather than Mozilla?

well, why is it working with IE then?

Comment 8

14 years ago
Quite often we see this with, for example, display drivers, printer drivers,
etc.  A specific call by Mozilla triggers a bug in the drive, which is not shown
up by other software.  But that doesn't make it a Moz bug - apps that Mozilla
calls should "behave" as expected, and handle errors themselves cleanly.  I just
wondered if this is a similar issue - something specifically wrong in
RealAlternative which IE doesn't call, but which Mozilla does.  I'm no
programmer - this needs someone who knows their stuff to look at it!

Comment 9

14 years ago
*** Bug 243265 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
hm.. dunno why exactly, but suddenly it works for me. seems like real alternate
player has to be installed fully w/all components even though i had media player
classic 6.4.xx installed at another location already. my guess is that mozilla
crashes when real alternate cannot find a proper player (wmp classic) at the
default installation location from real alt install routine. so @all that have a
prob, try real alt 1.23 full install and see if that may work for you.

Comment 11

14 years ago
Just out of interest, my Linux Firefox 1.0 also crashes with those files.

I first found this when trying to listen to the streaming audio at:

www.rrr.org.au

My version info is:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050226 Firefox/1.0
(Ubuntu) (Ubuntu package 1.0.0+dfsg.1-6ubuntu1~4.10ubp1)
Assignee: bross2 → nobody
QA Contact: general
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 12

6 years ago
does this still reproduce or you?
note: website is now flash
Flags: needinfo?
(Reporter)

Comment 13

6 years ago
Boy this is a really old bug. I haven't used Real Player in ages. I say close this ticket.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.