[spellcheck] weird gaps in capitalization checking lead to checking errors

VERIFIED INVALID

Status

SeaMonkey
Composer
VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: Ian Graham, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

This was detected in the mail composition editor, and verified in composer
(English/United States dictionary).  

If I compose a message as follows (between horizontal dashed lines)

------------
Here is the test letter.

january January
february February
march March
april April
may May 
June june 
july July
august August
september September
october October
November november
december December
---------------

the spellchecker claims that some of the lowercase month names are incorrect
(i.e.  january, february, april, june, july, september, october, november,
december), and proposes ridiculous alternative spellings in some cases (e.g.
june --> jun, rune, etc.).

This seems just wrong, somehow. 



Reproducible: Always
Steps to Reproduce:
1. cut  text between dashed lines above paste into a composer (or mail)
2. paste into a composer (or mail composition) window
3. run spellcheck (English/US language)

Actual Results:  
Detects incorrect spelling errors.

Expected Results:  
Should be able to spell names of months.

Comment 1

15 years ago
dup of bug 237276?
(Reporter)

Comment 2

15 years ago
No, I don't think so.  The problem is that, in some cases, spellcheck sees both
capitalized and non-capitalized forms as correct (e.g. both 'march' and
'March'), while in other cases it sees only the capitalized form as correct
(e.g. 'January' is ok, but 'january' is seen as spelling error). 

I don't know why this is so -- there is nothing in the dictionary file
(en-US.dic) to indicate any distinction between, say, January, and March... 

Comment 3

15 years ago
how about the fact that march is a verb (and noun). it's what some kinds of 
bands do.

may is a qualifier thingee. you may not understand what may means, but you can 
be assured that may is a word and maybe you should consider that, otherwise you 
will be embarassed.

this is either a duplicate or invalid. take your pick.
(Reporter)

Comment 4

15 years ago
Resolving as invalid (for now) -- will look at some other spellcheckers, and
either reopen or report as a different bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
verified invalid -- other spellcheckers do the same thing (modulo better support
for lower/upper case rules -- see bug 128122 )

Updated

15 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.