Closed Bug 237506 Opened 21 years ago Closed 21 years ago

− entity render as "?" character

Categories

(Core Graveyard :: GFX: OS/2, defect)

x86
OS/2
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 189480

People

(Reporter: samm, Assigned: mkaply)

References

()

Details

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6) Gecko/20040117
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6) Gecko/20040117

Mozilla/OS2 render − entity as "?".
Mozilla on other platforms render this character correctly.

Reproducible: Always
Steps to Reproduce:
1.open url
2.do "source view" ;-)


Actual Results:  
"?" sign display, not "minus" sign.

Expected Results:  
dislplay "minus" sign.
can confirm that in 1.6 release. in natinal charsets '−' is shown as '?'.
and I can't see any other way to add non-breakable '-' sign....
This is actually a bug in the OS/2 decoders.

They don't properly convert that unicode character on a number of codepages (the
question mark means OS/2 didn't know what to convert it to).

This will be fixed if we ever move to use Mozilla's codepage converters.

*** This bug has been marked as a duplicate of 189480 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.