Bugzilla logout in buglist.cgi (formerly "Search not working anymore")

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: StK, Assigned: justdave)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

Since i updated to 2.17.7, bugzilla cann't find all my bugs.
Doing the same search with 2.17.6, more (and the right) bugs are found.


Reproducible: Always
Steps to Reproduce:
I can reproduce it everytime!
Actual Results:  
a searck for "böck" gives me 0 bugs, with 2.17.6 I got 2 bugs.

Comment 1

14 years ago
Does querying for terms that are in plain ASCII work as expected? 
(Reporter)

Comment 2

14 years ago
No, it doesn't.
I did no modification on bugzilla, except, i use the german templates, which 
aren't finished 100%.
But the same templates work well in 2.17.6
This time i did a querry for "verzeichniss" without any success.

When i search for "page" i find 3 bugs. So searching in general works sometimes.

Comment 3

14 years ago
See Bug 237937 (confirmation of this bug?)
(Reporter)

Comment 4

14 years ago
I did select all Status on the query page, so this isn't the same bug.
I'm now working again with 2.17.6 which is working!

Are there any tests i can do to find a solution?
(Reporter)

Comment 5

14 years ago
So i did several tests....
this also occurs when i use the english templates of 2.17.7.
(Reporter)

Comment 6

14 years ago
With
&debug=1
i found out, that Bugzilla changes the saved sql-satement from the working
2.17.6 query:
SELECT bugs.bug_id, bugs.bug_severity, bugs.priority, bugs.bug_status, 
bugs.resolution, bugs.bug_severity, bugs.priority, bugs.rep_platform, 
map_assigned_to.login_name, bugs.bug_status, bugs.resolution, 
bugs.target_milestone, bugs.short_desc FROM bugs, profiles AS map_assigned_to 
LEFT JOIN bug_group_map ON bug_group_map.bug_id = bugs.bug_id AND 
bug_group_map.group_id NOT IN 
(27,29,24,20,19,26,22,4,10,25,23,14,2,28,3,6,18,16,12,9,13,21,1,11,7,17,5,8,15) 
LEFT JOIN cc ON cc.bug_id = bugs.bug_id AND cc.who = 1 WHERE bugs.assigned_to = 
map_assigned_to.userid AND (bugs.target_milestone IN ('4.101')) AND 
(bugs.bug_status IN 
('UNCONFIRMED','NEW','ASSIGNED','REOPENED','RESOLVED','VERIFIED')) AND 
((bug_group_map.group_id IS NULL) OR (bugs.reporter_accessible = 1 AND 
bugs.reporter = 1) OR (bugs.cclist_accessible = 1 AND cc.who IS NOT NULL) OR 
(bugs.assigned_to = 1) ) GROUP BY bugs.bug_id ORDER BY bugs.bug_id 


to this query:
SELECT bugs.bug_id, bugs.bug_severity, bugs.priority, bugs.bug_status, 
bugs.resolution, bugs.bug_severity, bugs.priority, bugs.rep_platform, 
map_assigned_to.login_name, bugs.bug_status, bugs.resolution, 
bugs.target_milestone, bugs.short_desc FROM bugs, profiles AS map_assigned_to 
LEFT JOIN bug_group_map ON bug_group_map.bug_id = bugs.bug_id WHERE 
bugs.assigned_to = map_assigned_to.userid AND (bugs.target_milestone IN 
('4.101')) AND (bugs.bug_status IN 
('UNCONFIRMED','NEW','ASSIGNED','REOPENED','RESOLVED','VERIFIED')) AND 
((bug_group_map.group_id IS NULL)) GROUP BY bugs.bug_id ORDER BY bugs.bug_id 

what's going on here?

Comment 7

14 years ago
The first query seems to be looking for bugs that are accessible by a user with 
user_id = 1.

The second seems to be looking for only publicly visible bugs.


Might you be doing the 2.17.6 search on a bugzilla installation that you are 
already logged into, and the 2.17.7 search without logging in?

Do the bugs have restricted visibility?
(Reporter)

Comment 8

14 years ago
Yes, the bugs are restricted, but i'm logged in!

What i found out is that bugzilla seems to log me out (bottom right is no email 
adress) if I do a search...
But only on the buglist.cgi site where bugzilla shows all found bugs.
When i change back to the the search site (via Link) bugzilla semms to be 
logged in again.

Any further hints?

Comment 9

14 years ago
Could it be that you just have a broken bugzilla cookiepath value, or cookies
disabled?
(Reporter)

Comment 10

14 years ago
No!
Everything works, just the resultpage says that i'm not logged in.
Clicking on any Bug on the resultpage shows me the bug and says that i'm logged 
in.
I did a fresh installation with the same result. 
I used the original english templates... same result.

Could it be a bug in buglist.cgi having problems with the cookie?

Should i try to use buglist.cgi from 2.17.6?
we used to have a bug a LONG time ago where users would appear to be logged out
on the query results page and only on that page due to a propogation delay to
the shadow database, and the data for the footer was getting pulled from the
shadow database only on the search results page (the fix was to have it switch
back to the primary database before displaying the footer).  That bug was
pre-templatization, however, and all of that data is loaded before anything is
done with a query, now, so that's very unlikely to be the situation this time...

Comment 12

14 years ago
stk:  Are you using a shadow database?
(Reporter)

Comment 13

14 years ago
no, no shadow database.
the only thing i use heavvily is groups and their access rules.


Changing the title to
"Buglilla logout in buglist.cgi", because this seems to be the problem.
As i already explained: When i do a search, buglist.cgi shows an nearly empty 
list of found bugs because the user seems to be logged out (and most bugs are 
only accessible for a special group). When i klick on any found button or on 
any other link on the site, i seem to be logged in again.


The problem still exists, but i seem to be the only one.
Summary: Search not working → Buglilla logout in buglist.cgi (formerly "Search not working anymore")
(Reporter)

Comment 14

14 years ago
Today i downloaded 2.17.7 from cvs an... it works!
2.17.7 tar still doesn't work.
I've no idea what's the reason for it.... so i'm closing the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 15

14 years ago
may as well avoid confusion in release notes,  marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Summary: Buglilla logout in buglist.cgi (formerly "Search not working anymore") → Bugzilla logout in buglist.cgi (formerly "Search not working anymore")
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.