all events show up after resize filtered event list (unifinder)

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Caliga (Daniel St.), Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.6) Gecko/20040113

if you use a filter for the event list, all events will be shown if the event
list  gets resized. i guess this forces an update / redraw.
my cousin, who informed me of this, says he has to click into the events list
after resizing to cause this "redraw". i just have to resize.
resize means, dragging the divider between the event list and the calendar view
under it. Resizing the application window does NOT lead to this.

Reproducible: Always
Steps to Reproduce:
1. type a filter word in the line above the events
2. drag the divider between events and the calendar up or down
3. optionally click in the events list
Actual Results:  
the full, unfiltered list appeared

Expected Results:  
the filtered list should remain
(Reporter)

Comment 1

14 years ago
Bug 237311 (or dupe bug 168495)
may be related.
Both cases lead to a redraw that draws more events than wanted.
The eventlist has changed since the filing of this bug and I cann't reprduce the
behaviour. WFM TB 0.8 and extension 2004100812.

The related bugs mentioned in Comment #1 is however still alive

Comment 3

13 years ago
This also happens with Mozilla Calendar in Firefox as of 2005011112-cal

Comment 4

13 years ago
*** Bug 278241 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
Confirmed.

Status: NEW
Hardware: All
OS: All

Added 'unifinder' to the summary
OS: Windows XP → All
Hardware: PC → All
Summary: all events show up after resize filtered event list → all events show up after resize filtered event list (unifinder)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
Works for me on trunk.  Reporter, if you can still reproduce this on a nightly
build, you may reopen, but be sure to include your version information.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.