If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

closing an empty tab with ctrl-w puts focus in URL bar

RESOLVED INVALID

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Darin Fisher, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
closing an empty tab with ctrl-w puts focus in URL bar.  this behavior was
introduced in mozilla 1.6.  in mozilla 1.5, closing an empty tab with ctrl-w
would focus the next tab.  note: if only two tabs are open, then closing one tab
continues to focus the browser window.  the problem only occurs when you start
with three or more tabs open.

i've only tested linux builds.  this also affects recent seamonkey and firefox
builds.

i don't have more information on when this regressed / changed.  is it even a
regression?  (i think so since it is inconsistent with the behavior that occurs
when you start with two tabs.)
(Reporter)

Comment 1

14 years ago
what we need to do is try out older builds to narrow down the window in which
this changed.
Darin, if you can give me explicit steps to reproduce (because I'm failing to do
so thus far), I can probably give you a small regression window....
(Reporter)

Comment 3

14 years ago
here's the steps that i used:

1) open browser, click in the browser window
2) open new tab using ctrl-t
3) open new tab using ctrl-t
4) click the browser window in the visible tab (giving focus to the browser window)
5) press ctrl-w
6) notice that focus is now in the URL bar
> 3) open new tab using ctrl-t

Where is the focus after this step?  If it's in the URL bar, then what's
probably happening is that our "restore focus to the thing that had it when this
tab was focused" code is working... code that was checked in for 1.6.
(Reporter)

Comment 5

14 years ago
yes, in fact after step 3 the focus is in the URL bar.  and indeed if i click on
the browser window after pressing ctrl-t, and then open another tab and close
the tab (with ctrl-w) the focus returns to the web page of the previous tab. 
so, it sounds like things are working as designed.

i guess that it makes sense for a new tab to place focus in the URL bar.

resolving this bug as INVALID.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

13 years ago
Component: XP Miscellany → Tabbed Browser
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.