page layout is bad on first load but good on reload

RESOLVED DUPLICATE of bug 242159

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 242159
14 years ago
14 years ago

People

(Reporter: Oliver Hutchison, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When you initaly load this page there is a large amount of white space in the
central content area which sould not be there. However if you do a reload of
this page the whitespace goes and the layout is corect.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.ourcommunity.com.au/business/business_main.jsp
2. look at all the white space at the top of the center content area
3. hit realod
4. notice that the white space is gone
Actual Results:  
the browser lays out page with identical HTML in 2 diferent ways

Expected Results:  
it should always render identical HTML in an identical way

Perhaps this is related to a caching issue as if i clear the cache it will
render with all the whitespace again.
(Reporter)

Comment 1

14 years ago
Created attachment 144013 [details]
this is the HTML for the link http://www.ourcommunity.com.au/business/business_main.jsp

This is the HTML for the link
http://www.ourcommunity.com.au/business/business_main.jsp. I'll probably fix
the live code so this should be used insted of link for testing.

Comment 2

14 years ago
I see this too on LInux 2004041908  
You can add height="44" to the image to make it work.  I belive the problem is
Moz wrongly guesses the height before it loads the image.  When it finnally gets
the image it does not bother to reflow the page. 

Comment 3

14 years ago
Duping to a newer bug about the same issue, since the newer bug has a testcase
already written.

*** This bug has been marked as a duplicate of 242159 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.