view current style of node

RESOLVED WORKSFORME

Status

Other Applications
DOM Inspector
--
enhancement
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: David Mårtensson, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

I would like an option to se all current style of a node.

This is usefull when debugging to check why a node does not behave as expected,
it might be a class definition that adds some extra style that is not visible in
the source directly and also to see when a block node is rendered to big due to
problems with child nodes.

Sometimes it is not obvious which styles that is inherited and whichs is not and
if you have an external stylesheet there could be difficult to predict a complex
document.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
None

Expected Results:  
To have some option names "Current style" or "preferences" either on rightclick
or  in the information box.
One of the info panes on the right is "computed style", which is exactly what
you want, no?
"CSS Style Rules" gives you exactly what you want, as far as I can tell. Click
the pane chooser thingy in the right pane and choose it.

marking wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
Ahh, thanks, did not understand that you could change that.

Maybe time to add a help section for DOM inspector.

Unfortuanatly it Bombed out on me when I tried to switch to CSS Style Rules.

I'll try it some more but is there som known bugs with that?
Product: Core → Other Applications
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.