Java applet param list doesn't entirely initialize

RESOLVED DUPLICATE of bug 217715

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 217715
14 years ago
14 years ago

People

(Reporter: Jeremy Adams, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When a java applet is embedded in a page (either with the applet or object tag)
and has a list of parameters via the param tag, not all of the parameters load
every time the applet is initialized.

Reproducible: Sometimes
Steps to Reproduce:
1. Setup an applet that loads a list of param tags and then prints out the
values for each tag.
2. Load the page. If you refresh, or the page takes a little bit to load, you'll
see that not all the parameters were passed to the applet.
3.

Actual Results:  
It seems to be random where the list of parameters ceases to load, but always
goes in sequential order, and then stops somewhere.

Expected Results:  
The applet should be able to view and utilize all the paramters passed to it in
the param list.

If I save the page down locally, the issue is nearly impossible to reproduce
sine the page loads so quickly. However, when viewing pages across the web, it
occurs far more frequently, especially on sites that use server-side scripting
to dynamically build web-pages (such as php, asp, jsp, etc.). I have tried
coding php to first gather all the information into an array and then spit out
the entire applet tag and the following param list at the exact same time, but
that didn't help. It seems to occur simply if any part of the page takes a few
moments to load.

Our sites rely a great deal on java applets for things such as menu navigation
and dynamic site monitoring.

Comment 1

14 years ago
I believe I am also seeing this bug at this page: 

http://www.go4go.net/english/sgfview.jsp?id=4578 

If that exact page becomes unavailable, simply use http://www.fo4go.net/english/
and click on any goboard icon (the yellow with black and white dots icon). The
applet used on this page is for viewing Go games and one of the params I see
when I view source appears to contain either a key to the smart game format file
on their server or perhaps it is merely an encrypted or compressed version of
the SGF data. The latter seems more likely since the tag is way too long for any
sensible key. The applet loads, and draws a board, but shows up empty in Firefox
0.8 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206
Firefox/0.8). 

Here's the interesting part that may help: When I hit the back button and then
the forward button suddenly the applet shows the game! Apparently it only fails
to get the parameter on the inital load but if you browse away and come back it
then works like a charm.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 217715 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.