If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Get New Themes" does not work when Options is opened from Download Manager

RESOLVED FIXED

Status

()

Firefox
Preferences
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Mridula, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

While using Tools->Downloads->Options->Themes, then select "Get New Themes"
nothing happens,but if we do Tools->Options->Themes and then select "Get New
Themes" a new windows opens
from where the user can install, submit or check out for avaiable themes.
Same problem can be seen,if we select "Extension" instead of "Themes" and then
select "Get New Extensions", but it works fine if we select
Tools->Options->Extensions and then select "Get New Extensions".


Reproducible: Always
Steps to Reproduce:
1. Select "Tools->Downloads” menu 
2. Click on "Options" 
3. Select "Themes"
4. Select "Get New Themes", nothing happens.


Actual Results:  
Nothing happens when we select "Get New Themes".

Expected Results:  
A window should pop up from where the user can install, submit or check out for
avaiable themes.

Comment 1

14 years ago
This also affects the extension author links, see Bug 236241 for a related problem.

Comment 2

14 years ago
Yeah, certainly looks like a dupe of bug 236241 (similar concept, anyway). Mike,
what do you think?
not a dupe, but related (same fun with having a non-browser parent)

Comment 4

14 years ago
--> NEW
--> Preferences
--> All/All
Assignee: bugs → firefox
Status: UNCONFIRMED → NEW
Component: Downloading → Preferences
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: aebrahim → mconnor
Hardware: PC → All

Updated

14 years ago
Summary: In Tools->Downloads->Options->Themes: "Get New Themes" does not work → "Get New Themes" does not work when Options is opened from Download Manager
(Reporter)

Comment 5

14 years ago
User-Agent:- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040330 Firefox/0.8.0+
The above bug# 237660 could be replicated in Windows 2000 with Firefox 0.8+.
(Reporter)

Comment 6

14 years ago
User-Agent:- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040330 Firefox/0.8.0+ 
OS- Windows 2000.

When we darg and drop "Download" in the "Nagivation Toolbar", from
View->Toolbar->customize,then click Download->Options->Themes->Get New Themes,
nothing happens.

Steps To replicate:-
1)Click on View->Toolbar->Customize
2)Drag "Download" and drop on the "Navigation Toolbar"
3)Click on Download->Options->Themes->Get New Themes

Obtained Result
Nothing happens when we select "Get New Themes"

Expected Result
A window should pop up from where the user can install, submit or check out for
avaiable themes.
We know its broken, we just haven't decided on a fix yet :)

I wonder if hiding the categories panel and just showing the downloads portion 
of the prefwindow would be a good compromise, unless we want to engage in some 
trickery :)

Comment 8

13 years ago
This looks the same as 228932, probably could be marked fixed also.
true!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.