Calendar does not honor system colors (even in Classic) and in some cases is illegible

RESOLVED INVALID

Status

Calendar
Sunbird Only
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Jonadab the Unsightly One (Nathan Eady), Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113 GalionPublicLibrary/1.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113 GalionPublicLibrary/1.1

First off, parts of the calendar just completely ignore the system background
color, showing for example a garish blinding white irrespective of the user's
preferences.  This is fine for Modern but should not happen in Classic.

Second, these areas nevertheless do use the system foreground color for text,
against their custom background, and the results are illegible if the system
defaults are set to light text on a dark background.  This is not fine under
any circumstances, even under the Modern theme.

Reproducible: Always
Steps to Reproduce:
1. Set system colors to something other than black on white.  For example,
   use the thEmacs theme for GTK.
2. Turn off page colors in your system prefs.  (Not sure if this step is
   necessary for the bug to manifest.)
3. Install the Calendar XPI.
4. Open the calendar and attempt to look at it.

Actual Results:  
System-default-foreground text is illegible on custom background color.

Expected Results:  
In Classic, system default background color should be used.
In Modern, the foreground color for the text should be specified.

The provided URI shows a screenshot taken under Linux/Gnome, but the issue
occurs on Win32 also.  It probably does not occur on platforms that do not
provide a facility for changing the default background color (e.g., Mac, BeOS).
Here is a partial list for Classic (from calendar.css):
The following need to set background-color to a system background color:

#month-view-box
#day-view-box
.day-view-event-class
.day-view-hour-box-class[draggedover="true"]
#week-view-box
#weekview-header-spacer-left
#weekview-daynumber-spacer-mid
#week-view-header-spacer

.month-day-box-class[empty="true"]
.month-day-event-box-class[eventselected="true"]
.day-view-event-class[eventselected="true"]
.week-view-event-class[eventselected="true"]
.week-view-hour-box-class[draggedover="true"]

.month-column-center-day-class
.month-day-box-class
.month-day-event-box-class
.month-day-event-box-class:hover
#day-view-content-box
.week-view-event-class
.week-view-hour-box-class

.month-day-box-class[today="true"]
#week-view-content-holder
.week-view-hour-box-class[today="true"]
.week-view-hour-box-class-last-day[today="true"]
#week-view-all-day-content-box

.month-day-box-class[monthselected="true"]
.month-day-box-class[monthselected="true"][weekend="true"]
#all-day-content-box
#week-view-content-outer-box
Created attachment 144066 [details] [diff] [review]
Highly tentative proposed patch (for skin/classic/calendar.css), version 1

This is tentative and may not in all cases use the ideal system color.	Also,
it makes very little attempt to change border colors, and it doesn't touch 
Modern at all.
Screenshot using that first tentative patch:
http://cgi.galion.lib.oh.us/mozilla/2004_03_16_154411_shot.jpg
I'm in no position to judge the proposed fix for this but there problem is/was
there and needs some kind of attention. Of course looks is important when
"selling" a product.
cc-ing the theme master

Comment 6

14 years ago
Please submit a unified patch.

The changes in this patch are not a complete solution.

1. Month day cells still have a hard coded border color. If the system
background color were set to a light blue this would render the month days
invisible. Using either WindowFrame or ThreeDDarkShadow seems appropriate.

2. Month day heading and week number cells are not set apart. These areas must
be highlighted by more than simply bold text. Using ThreeDShadow (bg) and
ThreeDFace (fg) might be the solution.

3. The other views (day, week, etc.) will have similar issues.

I don't see this as being an urgent change so I will (and have already started
to) incorporate these changes into my Sunbird calendar area redesign and make
sure that calendar/classic gets updated at the same time, unless Mostafa or
someone else disagrees.

Comment 7

14 years ago
Chris, 
any update on your Sunbird calendar area redesign?

Updated

13 years ago
QA Contact: gurganbl → sunbird
Marking WONTFIX because XPI-only?
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Is this bug still valid? Has some work to be done in this field? -> qawanted
Keywords: qawanted
INVALID, because this bug applies to the calendar xpi.

If such issues (system colors not honored) still arise, please open new bugs for individual issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.