Context menu item Search Web should also work in <textarea> and <input> field

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
13 years ago

People

(Reporter: jaap, Assigned: jaap)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

The Search Web "...." does not work when you select text in a <textarea> or
<input> field

Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
Created attachment 144074 [details] [diff] [review]
Patch which implements requested feature


The following part in the patch does something extra then the requested
feature.
It removes certain characters such a ,:?! at the end and beginning of words.
These characters are usually not useful and can confuse the search engine.
I have implemented like this for the dictionarysearch extension
http://dictionarysearch.mozdev.org because these characters confuse some of the
online dictionaries. Furthermore if you doubleclick on a text like:  " hello, "
it will select " hello, " while you probably would like to search for " hello "


+	 selection = selection.split(" ");
+   
+	 // Remove certain characters which make searching more difficult at
the beginning and end 
+	 // of every word
+	 for (i=0; i<selection.length; i++){
+	    
selection[i]=selection[i].replace(/^(\&|\(|\)|\[|\]|\{|\}|"|,|\.|!|\?|'|:|;)+/,
"");
+	    
selection[i]=selection[i].replace(/(\&|\(|\)|\[|\]|\{|\}|"|,|\.|!|\?|'|:|;)+$/,
"");
+	 }   

+	 selection = selection.join(" ");
(Assignee)

Updated

15 years ago
Attachment #144074 - Flags: review?(firefox)

Comment 2

15 years ago
Your patch, your bug
Assignee: firefox → jaap
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

15 years ago
(In reply to comment #2)
> Your patch, your bug
?????
I'm afraid I do not understand you. This is the first time I submit a patch so
please bear with me ;-)

Comment 4

15 years ago
You supplied a patch, so this bug is assigned to you.
(Assignee)

Comment 5

15 years ago
(In reply to comment #4)
> You supplied a patch, so this bug is assigned to you.
Fine

What should I do now to get a review? I put firefox@blakeross.com as reviewer.
Should I now just wait or should I contact somebody.

My apologies for being so ignorant ;-)
Status: NEW → ASSIGNED
You haven't given a reason why the textarea/input context menu should be
anything other than the current items.  The context menu in textareas is
specifically set up to be used for editing text and ONLY editing text.  Adding a
web search there doesn't make sense to me.  If you want to enter text to search
the web, use the searchbar.  Maybe on open wikis where content is displayed in
styled textareas, but that's an edge case that doesn't make sense for normal users.

If you really want this functionality, I would recommend that you create an
extension, because it doens't make sense for most users of the application.

-> WONTFIX, ccing ben in case he wants to overrule me, but I doubt it.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

15 years ago
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX

Comment 7

15 years ago
FIXED is not the correct resolution
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

15 years ago
I guess this is what Mike wanted.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX

Comment 9

15 years ago
Oops! That happens if you wait 30 minutes with reading your bugmail :-)
(Assignee)

Comment 10

15 years ago
(In reply to comment #6)
> You haven't given a reason why the textarea/input context menu should be
> anything other than the current items.  The context menu in textareas is
> specifically set up to be used for editing text and ONLY editing text.  Adding a
> web search there doesn't make sense to me.  If you want to enter text to search
> the web, use the searchbar.  Maybe on open wikis where content is displayed in
> styled textareas, but that's an edge case that doesn't make sense for normal
users.
> 
Mike, I can agree with your reasoning.

I've had the feature requested a couple of times for dictionary search. People
liked to have it for Dictionary Search in case they are writing (or replying) to
an email in for example yahoo mail. (It makes also more sense for dictionary
search then for web search)

I implemented it for dictionary search so I thought why not propose a patch for
Firefox. I at least learned now how to build firefox and propose patches :-), so
I hope in the future I can submit more useful patches :-)
Comment on attachment 144074 [details] [diff] [review]
Patch which implements requested feature

ooh, nice extension.  Spell checking in textareas is useful for some people,
but not for everyone.  Its the perfect example of how powerful extensions
really are.
Attachment #144074 - Flags: review?(firefox)

Comment 12

14 years ago
*** Bug 277911 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
I would use this when searching and I want to alter my current search but have
it open in a new tab, so I can then compare the two.

Comment 14

13 years ago
Now, there are a lot of wikis, a lot of blogs and a lot of webs with content edition. I think that is very usefull the search in text area, and every day more and more.

Take that in cosideration.

Updated

13 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.