packages-unix misses files?

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
15 years ago
3 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114

at least the following files are not in packages-unix but in mozilla.org's
distribution:

components/htmlparser.xpt
components/jsconsole.xpt
components/lwbrk.xpt
components/nsInterfaceInfoToIDL.js
components/nsResetPref.js
components/nsUpdateNotifier.js
components/plugin.xpt
components/prefetch.xpt
components/ucnative.xpt
res/arrowd.gif
res/viewer.properties

and profile-sharing stuff:
components/profilesharingsetup.xpt
ipc/modules/liblockmodule.so
ipc/modules/libtransmgr.so
mozipcd
components/ipcd.xpt
components/libipcdc.so

the problem is, that some mozilla distributions create their file-lists out
of this packages file and the files are missing then.
It's almost impossible to know which files are really needed :-(
I see two possibilities:
1. improve the packaging mechanism 
2. make install does reliable install only needed files


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
packages-unix seems to be a little outdated and not fixable because of different
compile settings easily. So closing now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.