Status

RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: abwillis1, Assigned: mostafah)

Tracking

Details

Attachments

(4 attachments, 5 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040314
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040314

This is a bug to submit my patches to get Calendar working under OS/2.

Reproducible: Always
Steps to Reproduce:
I have now gotten calendar to work under OS/2.
(Reporter)

Comment 1

15 years ago
Created attachment 144140 [details] [diff] [review]
allmakefiles.sh

allmakefiles has calendar being built before the other-licenses which on OS/2
causes an error that mozillas_s.a cannot be found.  I just reversed them but as
I don't know how it was working this way on the other systems I don't know that
reversing them won't break other platforms.  I don't know shell scripting to
write proper ifdef's in it.
(Reporter)

Comment 2

15 years ago
Created attachment 144141 [details] [diff] [review]
createxpi.sh
(Reporter)

Updated

15 years ago
Attachment #144140 - Attachment is patch: true
(Reporter)

Comment 3

15 years ago
Created attachment 144142 [details] [diff] [review]
makefile.in from calendar diretory

The objdir could use some massaging.
(Reporter)

Comment 4

15 years ago
Created attachment 144143 [details]
OS/2 xpi creator.

I use this file to create the xpi on OS/2 as make xpi didn't do anything.  On
OS/2 I am not getting a makefile created in the Calendar directory, I am having
to assume at this point that this is due to the way that configure works as I
don't really understand it.
(Reporter)

Comment 5

15 years ago
Created attachment 144144 [details]
calender.ico

This needs to be put into mozilla/calendar/os2/icons/default that needs to be
built created as well.
(Reporter)

Comment 6

15 years ago
Created attachment 144146 [details] [diff] [review]
makefile.in in libxpical directory

I don't understand really why this was needed.	On OS/2 we get mozicals.lib
instead of mozicalss that I assume it has something to do with OS/2 having a
8.3 dll restriction.
(Reporter)

Comment 7

15 years ago
Created attachment 144149 [details] [diff] [review]
makefile.in from caledar directory

I figured out the problem with the makefile not being created, it was my
mistake here so I corrected the makefile.in
Andy
Attachment #144142 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #144146 - Attachment description: makefile.in → makefile.in in libxpical directory
(Reporter)

Comment 8

15 years ago
Created attachment 144158 [details] [diff] [review]
calendar makefile.in

Realised that if platform was windows that it would be set then it would be
changed to linux.  A more elegant method would be better than this.
Attachment #144149 - Attachment is obsolete: true
(Reporter)

Comment 9

15 years ago
Created attachment 144159 [details] [diff] [review]
makefile.in in calendar directory.

One more change to makefile.in, OS/2 needs to specify to run perl for .pl
files.
Attachment #144158 - Attachment is obsolete: true
(Assignee)

Comment 10

15 years ago
*** Bug 224439 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
Nice.

That $(PERL) change in the last diff can probably be done for everyone.

I'll these changes in tomorrow if I can.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Andy, the allmakefiles.sh change should be unnecessary.  The order in that file
does not affect compilation order.  This file only exists to create the
"Makefile" from the "Makefile.in".  The compilation order of those directories
is handled by the top level Makefile.in.  And in fact, that Makefile.in has this
line:

   ifdef MOZ_CALENDAR
   tier_98_dirs    += other-licenses/libical calendar
   endif

So it should already be building 'other-licenses/libical' before 'calendar'.
(Reporter)

Comment 13

15 years ago
(In reply to comment #12)

> 
> So it should already be building 'other-licenses/libical' before 'calendar'.

I will change it back and verify.  When I first got the error I did a search on
google and found a reference that said to look for *mozical* and I didn't have
one.  I changed the order and got one but it then failed due to the extra (or
missing depending on perspective) s.  I didn't change the order back after
changing everything else.
Andy
(Reporter)

Comment 14

15 years ago
(In reply to comment #12)
> Andy, the allmakefiles.sh change should be unnecessary. 
I have verified that it indeed does work with the original allmakefiles.sh,
which would explain why I couldn't understand it working on the others and not
OS/2 :)
Andy
(Reporter)

Updated

15 years ago
Attachment #144140 - Attachment is obsolete: true
(Reporter)

Comment 15

15 years ago
Comment on attachment 144143 [details]
OS/2 xpi creator.

This is not necessary, I used it to create the xpi before I got make xpi
working.
Attachment #144143 - Attachment is obsolete: true

Comment 16

15 years ago
Nice work Andy.

Everything should be in with some subtle changes.

FYI,

1. that $(PERL) should have been used for everyone - no need to if it (look
earlier in the file)

2. the fact that SHORT_LIBNAME was definied for the libicalss was incorrect. We
only use SHORT_LIBNAME for DLLs and libicalss is a static lib. So instead of
your change, I just removed the SHORT_LIBNAME code.

I checked in the icon.

Thanks for your help motivating me to do this work. It's been on our list forever.

I'm marking this bug fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.