Linux crash in size_allocate

VERIFIED FIXED in M3

Status

()

P2
critical
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: dpp, Assigned: ramiro)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Using viewer to launch the latest code drop, trying to load any URL after the
first URL causes the program to fail.

Here's the output:


XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
nsWidget::Resize called.
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x8142bb8, {x=578, y=0, w=42, h=42}
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x80de398, {x=0, y=42, w=620, h=338}
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XP_GetString replacement needed
XP_GetString replacement needed
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x81ac1f8, {x=0, y=0, w=0, h=0}
size_allocate: 0x81ac6a8, {x=0, y=0, w=605, h=338}
size_allocate: 0x8191ec0, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=0, w=0, h=0}
size_allocate: 0x8142bb8, {x=578, y=0, w=0, h=0}
size_allocate: 0x80d8388, {x=0, y=28, w=620, h=372}
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x8142bb8, {x=578, y=0, w=42, h=42}
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x81ac1f8, {x=0, y=0, w=0, h=0}
size_allocate: 0x81ac6a8, {x=0, y=0, w=605, h=338}
size_allocate: 0x8191ec0, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=42, w=620, h=310}
nsWidget::Resize with x/y called.
size_allocate: 0x81ac1f8, {x=0, y=0, w=0, h=0}
size_allocate: 0x81ac6a8, {x=0, y=0, w=605, h=338}
size_allocate: 0x8191ec0, {x=0, y=0, w=620, h=310}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
XXX: return /tmp for fe_GetConfigDir
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x81ef720, {x=0, y=0, w=0, h=0}
size_allocate: 0x81f5338, {x=0, y=0, w=605, h=310}
size_allocate: 0x81b6bd8, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=0, w=0, h=0}
size_allocate: 0x8142bb8, {x=578, y=0, w=0, h=0}
size_allocate: 0x80d8388, {x=0, y=28, w=620, h=372}
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x8142bb8, {x=578, y=0, w=42, h=42}
nsWidget::Resize with x/y called.
nsWidget::Resize with x/y called.
size_allocate: 0x81ef720, {x=0, y=0, w=0, h=0}
size_allocate: 0x81f5338, {x=0, y=0, w=605, h=310}
size_allocate: 0x81b6bd8, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=42, w=620, h=310}
nsWidget::Resize with x/y called.
size_allocate: 0x81ef720, {x=0, y=0, w=0, h=0}
size_allocate: 0x81f5338, {x=0, y=0, w=605, h=310}
size_allocate: 0x81b6bd8, {x=0, y=0, w=620, h=310}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x81ef720, {x=0, y=0, w=0, h=0}
size_allocate: 0x81f5338, {x=0, y=0, w=605, h=310}
size_allocate: 0x81b6bd8, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=42, w=620, h=310}
size_allocate: 0x81ef720, {x=0, y=0, w=0, h=0}
size_allocate: 0x81f5338, {x=0, y=0, w=605, h=0}
size_allocate: 0x81b6bd8, {x=0, y=0, w=0, h=0}
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
nsWidget::Resize called.
size_allocate: 0x80de398, {x=0, y=42, w=620, h=310}

Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 4723 error_code 11 request_code 53 minor_code 0

aborting...

Updated

20 years ago
Assignee: joki → ramiro
Summary: The latest build fails to load pages → Linux crash in size_allocate

Comment 1

20 years ago
I'm not sure if this is a dupe of something else but it looks like it could be
somehow related to the resize issue.

Comment 2

20 years ago
Setting all current Open Critical and Major to M3

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 3

20 years ago
this should be fixed i believe.  someone verify?

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
verified...
You need to log in before you can comment on or make changes to this bug.