dependent windows do not always stay on top of parent

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
15 years ago
4 years ago

People

(Reporter: jay.weber, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [M1])

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040317
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040317

To reproduce, save this code to foo.xul

<window xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
  <script type="application/x-javascript">
    function test() {
      var features =
"dependent,close=no,minimizable=no,alwaysraised,width=200,height=150";
      window.open("http://www.mozilla.org", "", features);
      window.open("http://www.mozilla.org", "", features);
    }
  </script>
	
  <button label="test" oncommand="test()"/>
</window>

and click the test button a couple times, arrange the windows on top of the base
(parent) window.  Then start closing them one at a time, you will see that
*sometimes* the remaining windows stay on top, sometimes they disappear behind
the base window.  it is my understanding of the "dependent" feature that child
windows are supposed to stay on top.  Note that alwaysraised doesn't help.


Reproducible: Sometimes
Steps to Reproduce:
1. save code above to file, Open File
2. click test button a couple times, arrange child windows on parent
3. close windows one at a time

Actual Results:  
*sometimes* child windows go behind parent.  change focus and they come back

Expected Results:  
from the docs I've seen on the dependent and alwaysraised window features in
mozilla, child windows should always remain on top of the parent in the z-order.

Comment 1

15 years ago
Steps to reproduce as stated always WFM. However slightly modified steps always
show the bug for me:

Launch Mozilla, get a browser window.
Open a second browser window in front of the first.
Load the test page in the second window.
Click the "test" button. Get two more (dependent) windows.
Click the first browser window to bring it to the front.
Click the second browser window to bring it (and both dependent windows)
  to the front. Note you must use the mouse. Alt-Tab does not present the bug.
Close either of the dependent windows. (On my build, the second one is
  hidden behind the first. I have modifications; I'm not sure if that's
  normal. At any rate, don't move the topmost dependent window to get to
  its sibling, that'll squelch the bug.)
  Note either click its Close widget or click to activate and type Alt-F4.
  Both work. (Also note that after the previous step, while both dependent
  windows are drawn in front of thier parent, it's the parent that's active.)
  -- the remaining dependent window is sent behind its parent.

Quite right, dependent windows should always remain in front of their parent
window. alwaysraised even more so, though note that feature is simply ignored
when used in a window opened from unsigned script.

This looks like a Windows bug to me, similar to bug 22658 and bug 189085.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: dependent javascript windows do not always stay on top of parent → dependent windows do not always stay on top of parent

Updated

15 years ago
Whiteboard: [M1]
So this is the same as bug 243388, right? (which has a nice testcase)
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.