Bookmarks-Import doesn't give error message for invalid file format

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Amit Paspunattu, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In Bookmarks/Manage Bookmarks
On selecting File/Import, the dialog box appears which allows any file format to
be used as a bookmark. If it is a shortcut file, Firefox creates empty
directories in the bookmarks section and if it is an executable file, Firefox
doesn't do anything.


Reproducible: Always
Steps to Reproduce:
1.Click Bookmarks/Manage Bookmarks
2.Click File/Import
3.Select any file other than html files. For e.g. Select a shortcut file from
desktop. Firefox creates empty directories in the bookmarks section.

Actual Results:  
If the file selected is a executable, firefox did not do anything.
If the file selected is a shortcut file on desktop, firefox created empty
directories in the bookmarks section.

Expected Results:  
The browser should not have accepted other file formats as input and should have
given an error message.

Comment 1

14 years ago
Is this still a prob in 0.9?

Comment 2

14 years ago
Yes, this is still a problem. When I accidentally selected a not-bookmarks file
to import, the whole app hung momentarily and then nothing happened. No warning,
nothing.

This is something we should fix for 1.0
Assignee: p_ch → bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?

Updated

14 years ago
Assignee: bugs → vladimir
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P4
Uhm.  The difficulty here is that there is no way to detect a -correct- bookmark
file.  The file format is such that it looks like really badly misformed HTML. 
We can detect the exact format that we use to output, but I bet other things
which write "bookmarks.html"-format files don't use that exact same format...
Minusing for 1.0, simple patches welcome (simple meaning: "If zero bookmarks
were imported, give the user a warning").
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
Assignee: vladimir → vladimir+bm
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Updated

10 years ago
Severity: enhancement → minor
Component: Bookmarks → Places
OS: Windows XP → All
Priority: P4 → --
QA Contact: bookmarks → places
Hardware: PC → All
fixed in bug 422919 for Firefox 3. If the file is incorrect format, or fails to parse, we pop up an error to the user.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.