page appears to cache even though the page directives include 'no-cache'

RESOLVED DUPLICATE of bug 162545

Status

()

Core
Networking: HTTP
--
minor
RESOLVED DUPLICATE of bug 162545
14 years ago
14 years ago

People

(Reporter: Adam Blinkinsop, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

After visiting this site once (need referral from www.spu.edu; click on "Online
Learning" on the right), subsequent visits present a blank page.  Clearing the
cache will bring the original page back, but that original page includes two
meta tags that should disable caching of the page:

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Cache-Control" CONTENT="no-cache">


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.spu.edu/
2. Click "Online Learning" (right side, "SPU Virtual Campus")
3. Back (on the toolbar)
4. Click "Online Learning" again.

Actual Results:  
A blank page was loaded.

Expected Results:  
Load the original Blackboard login screen.

Workaround: While on the blank page, click
Edit->Preferences...->Advanced->Cache->Clear Cache, then refresh the page.

This is also a bug in the latest stable versions of Firefox (Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8) and
Netscape 7.1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)).
(Assignee)

Comment 1

14 years ago
the bug summary as written is invalid.  see bug 162545 (which is a duplicate).

see also:
http://www.mozilla.org/projects/netlib/http/http-caching-faq.html

Adam: to get the behavior you are expecting, the site must specify
"cache-control: no-store" in its response.  otherwise, Mozilla is allowed to
cache the documents for the purposes of back/forward navigation.

*** This bug has been marked as a duplicate of 162545 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.