Download manager forgets first download if second download has different URL but same filename.type

RESOLVED DUPLICATE of bug 157548

Status

RESOLVED DUPLICATE of bug 157548
15 years ago
5 years ago

People

(Reporter: douglas.godfrey, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Download manager forgets first download if second download has different URL but
same filename.type

download large file (>600k) from:
http://www.website.com/mainpage/subpage1/file.zip

while the first download is in progress, start a second download
with a different URL but the same filename and filetype/mimetype
http://www.website.com/mainpage/subpage2/file.zip

Only the second file actually gets downloaded. 

Reproducible: Always
Steps to Reproduce:
1.download large file (>600k) from:
http://www.website.com/mainpage/subpage1/file.zip

2.while the first download is in progress, start a second download
with a different URL but the same filename and filetype/mimetype
http://www.website.com/mainpage/subpage2/file.zip
3.

Actual Results:  
The first downloaded is forgotten as soon as the second download starts.

Expected Results:  
Both downloads should have completed. The filename of the second download 
should have been changed to file2.zip.
Whiteboard: DUPEME

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 157548 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.