Does not run certain javascript code to set input text value with, form.input.value = "value"

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: mike, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

Problem may extend to all versions of mozilla, the javascript engine does not
run the javascript to set input text values with, form.input.value = "value"

Reproducible: Always
Steps to Reproduce:
1. Find javascript function that sets the input text value with form.input.value
= "value"
2.Try to run the script
3.Mozilla will not run the script

Actual Results:  
It would not execute the javascript function.

Expected Results:  
Set the input text box value to a certain value.

Comment 1

14 years ago
I think this is a syntax problem with your JS.  Shouldn't that more correctly be:

document.form.input.value = "value";

I can't remember if that's exactly correct (the document prefix is needed, but
the rest afterwards looks like some sort of pseudo-HTML DOM that probably
doesn't work).

Comment 2

14 years ago
Invalid.  document.form.etc is correct syntax.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.