PAC: browsing for proxy auto config on local disk

UNCONFIRMED
Unassigned

Status

()

P5
enhancement
UNCONFIRMED
15 years ago
a year ago

People

(Reporter: cjensen, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-would-take])

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040316

It would be nice if there was a the ability to browse for a local file to use as
the Proxy Autoconfiguration file.
I've just started testing a new file, and am not 100% confident in the syntax
required to locate a local file (as opposed to http).

In general there is very little feedback - it would be nice if the reload button
flagged an error if it can't find the file for example.
This is really frustrating as there is very little in the way to discover if you
have correctly entered the location of the file without saving changes and
closing the preferences dialog.

Reproducible: Always
Steps to Reproduce:
1.Open Edit->Preferences
2.Go to Advanced->Proxies
3.Choose "Automatic Proxy Configuration file URL"
4.Enter an address of a file that doesn't exist.
5.Click on reload or Ok

Actual Results:  
Nothing - no feedback what so ever

Expected Results:  
Mozilla should warn me that the file I have specified cannot be found.

Comment 1

15 years ago
There is a basic error in the Javascript console.
Marking dupe of bug 133108 via bug 180145.

*** This bug has been marked as a duplicate of 133108 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
REOPEN:
This is a new request, as far back as I can remember.

That being said, few people use file URL's, so I think this is unlikely to be
implemented.

The easiest way to make sure you have the file URL is to view the directory it
lives in, and then do a Copy Link Location of the file you want to use.
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Networking
Resolution: DUPLICATE → ---
Summary: Allow browsing for proxy auto config → PAC: browsing for proxy auto config on local disk

Comment 3

15 years ago
-> NEW, future, defaults.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Future
Assignee: general → nobody
QA Contact: general → networking
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: [necko-would-take]
You need to log in before you can comment on or make changes to this bug.