can't filter by relative date

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: jarkun, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

I want to filter all email dated newer than "today", the option doesn't exist.

Ideally it would be newer than 1-month from today, 10% of my spam sent with bad
dates to artificially push it to the front of the list, I would like to
automatically ignore all this ****


Reproducible: Always
Steps to Reproduce:
1. select tools->message filters
2. select NEW
3. select DATA "is after"
4. there is no option to say "is after TODAY" or "is after 1 month from TODAY"


Actual Results:  
If I put in a hard-date, the filter is broken in 1 month

Expected Results:  
offered me the option to select 1 month from "today"
"Age In Days is less than 0" does not work on future date mails?

Comment 2

15 years ago
I just tried that and yes, it seems that "Age in Days -- Less than -- 0" works 
as expected, at least in 1.6 and 1.7b-0316.

Chris Goebel, you didn't mention which sort of mail account you're using.  
"Age in Days" is not available for IMAP mail accounts.  If you are using IMAP, 
please mark this bug as a duplicate of bug 177294.  If you are using POP, please 
mark this bug   Resolved|Invalid.
Product: MailNews → Core

Comment 3

14 years ago
No response from reporter; =>WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.