Cannot set up a new news account with a similar name as a current news account

RESOLVED DUPLICATE of bug 226303

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 226303
14 years ago
10 years ago

People

(Reporter: Nick Howitt, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7b) Gecko/20040318 Firefox/0.8.0+
Build Identifier: Mozilla Thunderbird 0.5+ (20040318)

I have a news account "NTL News" and I tried to set up an account called "NTL
News (text)". The wizard completed but nothing appeared to happen. I then
successfully set up an account called "Test", but it failed again when I tried
to set up an account called "Test 1"

Reproducible: Always
Steps to Reproduce:
1.Create a news account Test
2.Create a news account Test 1
3.

Actual Results:  
Nothing after the second

Expected Results:  
Set up a second news account
(Reporter)

Comment 1

14 years ago
This is now worse than I thought. Many of my attempts to create new News
accounts have left traces such that when I try to create them again, I am told
they already exist, yet I cannot see them.

Comment 2

14 years ago
I get this too. I suspect it's because you cannot have two differently named news accounts use the same 
news server.

Further, even though it appears that nothing happens - I tried to quit Thunderbird and start it up again, 
and then the name (my equivalent of "NTL News (text)") would appear.

Comment 3

13 years ago
I have a similar problem (under WinXP) with the Account Manager. I try create
two news accounts both having the same server name (the reason lies in the fact,
that the associated login/pass differ and lead to different newsgroup list).
After finishing the creation (with the "Add account" wizard) of the second
newsgroup, the second account does not appear in the account list.
Additionnally, the first newsgroup becomes unstable (I am asked to resubscribe
to each group each time I want to read the group). If I delete the first
newsgroup, then the second newsgroup becomes visible.

I don't now what the internal representation of accounts in thunderbird, but I
think that the indexing should be made independent from the actual content of
the accounts.

Comment 4

13 years ago
This sounds like my current quandary. I need to set up multiple news accounts,
each pointing to a different port of localhost. Thunderbird will not allow it.

Nor can I fool TB into creating an account and then changing its specs to
localhost. I keep getting "An account with that user name and server name exists".

Comment 5

12 years ago
(In reply to comment #3)
> I have a similar problem (under WinXP) with the Account Manager. I try create
> two news accounts both having the same server name<..> 

Related to/duplicate of bug 279169?

(In reply to comment #4)
> This sounds like my current quandary. I need to set up multiple news accounts,
> each pointing to a different port of localhost.

Related to/duplicate of bug 221313?

Comment 6

11 years ago
Confirmed on Thunderbird 1.5.0.7 on Windows XP SP2, and Windows Server 2003 SP1.

Trying to create several newsgroup accounts on the same NNTP server that require different authentication username/password combinations.

There is a twist to this because the Account Manager doesn't allow you to see the *actual* username associated with the account - it seems to assume 'username' is the account email address. This is evident when one authenticated account has already been set up and used (implies you've entered a username and password for the Password Manager) and then try to create a second account (whether requiring authentication or not).

I noticed that the Account Manager creates directories in the profile's ..\News\ folder of the form "news.domain.tld-X" for identical server names (where X is a an incrementing number), but tries to create resource files (.rc & .msf) with the same name as the server (doesn't postfix the "-X").

This obviously causes a conflict because the files for the new account can't be created, and explains how multiple accounts on the same server corrupt each other's properties.

Adopting the same name convention as for the account folders (adding "-X") would  seem to be a solution to the issue.

I tried to over-ride the name of the .rc file and folder from the account properties of the 2nd account but found it kept on switching back unpredictably.

Thats when I gave up and came to report the bug.


Comment 7

11 years ago
(In reply to comment #2)
> I get this too. I suspect it's because you cannot have two differently named
> news accounts use the same 
> news server.

I experienced exactly the same problem with SeaMonkey 1.0.6 under Ubuntu 6.06 GNU/Linux today. It's impossible to create a second account that would use a news server  already "in use" in a preexistent account. Voting for this bug.
QA Contact: account-manager

Comment 8

10 years ago
The actually problems seem to be getting fixed in bug 41929 and bug 238583. But as all TB bugs seem to be collected in bug 226303 I'm duping this to that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 226303
You need to log in before you can comment on or make changes to this bug.