ctrl-click to open link in new tab loses page focus

RESOLVED DUPLICATE of bug 151073

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 151073
14 years ago
14 years ago

People

(Reporter: Marc Bejarano, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219

right-click, choose "Open Link in New Tab" works as expected.  the new tab comes
to the forefront and the focus is on the page such that type-ahead find and page
up/down, etc work.  do the same thing, but instead use ctrl-click shortcut for
"Open Link in New Tab" and the focus is lost :(  ctrl-enter on link using
keyboard-only navigation is similarly broken.

Reproducible: Always
Steps to Reproduce:
1. navigate to http://mozilla.org
2. ctrl-click on "Download" link
3. try to press <Page Dn> key and notice that you've lost focus

Comment 1

14 years ago
I can confirm this.

Every time i use ctrl-klick on a link i can no longer use my scroll wheel to
scroll the page. The same happens when i rightklick an chooses open in new tab.

There seems to be several bugs relating to this.
bug# 231579,200950,238017,259374

Comment 2

14 years ago
Sorry about last comment it is in firefox i have this problem in mozilla it
works fine!

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 151073 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Product: Core → SeaMonkey
(Reporter)

Updated

14 years ago
Component: General → Tabbed Browser
Product: Mozilla Application Suite → Core
You need to log in before you can comment on or make changes to this bug.