Layout incorrect: Compare main boxes about centre of page with explorer

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Les. Satenstein, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

Explorer shows headings in the boxes that are of a clean good size. 
Mozilla has them smaller, and overtyped by the text below the headings in the boxes.

I am using 1.7 beta

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Other text overwrites      
      edit
The preceding word

Expected Results:  
        edit

The text that follows.
(Reporter)

Updated

14 years ago
Summary: Compare main boxes about centre of page with explorer → Layout incorrect: Compare main boxes about centre of page with explorer

Comment 1

14 years ago
Created attachment 144436 [details]
testcase

Overlaps because of "margin-top: -15px"

<td class="page" valign="top">
<p style="margin-bottom: 0px;">
<span style="font-weight: bold; color: rgb(0, 51,
153);"><center>Capture</center></span></p>
<ul style="margin-top: 15px; margin-bottom: 0px; margin-left: 20px;">
<li style="margin-top: 0px; margin-bottom: 5px;">First choose the type of
capture</li>
</ul></td>

<td class="page" valign="top">
<p style="margin-bottom: 0px;">
<span style="font-weight: bold; color: rgb(0, 51,
153);"><center>Share</center></span></p>
<ul style="margin-left: 20px; margin-top: -15px; margin-bottom: 0px;">
<li style="margin-top: 0px; margin-bottom: 5px;">Send your screen capture to a
file, an e-mail</li>
</ul></td>
IE's support for negative margins is pretty spotty... it's not handling this right.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Layout: HTML Frames → English US
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: core.layout.html-frames → english-us
Hardware: PC → All
Version: Trunk → unspecified
(Reporter)

Comment 3

14 years ago
Went to the web site and found that either my current version of mozilla 
includes a correction for negative margins, or that the webmaster at that site 
corrected his web page.

There is no way at this time to duplicate the error. Presume it is closed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.